Miwifimini wireless not broadcasting after upgrade from 18.X to 21.02

Device is miwifi mini.
I upgraded from OpenWrt 18 to 21.02.2 using Luci and the firmware provided on the wiki. After some https shenanegins I was back in and everything seemed to have been migrated.

However other devices can't see any wifi from the access point on 2.4G or 5G. I've removed and re-added the wireless networks but no effect. I've tried setting the transmit power to max and also to auto. Wireless scan works and sees other networks so the wifi isn't completely dead.

root@cabin:~# cat /etc/config/network

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fd8e:dfcf:78e5::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        option dns '8.8.8.8 8.8.4.4'
        option ipaddr '192.168.2.1'
        option device 'br-lan'
        option ipv6 'off'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '66:09:80:7b:cc:88'

config interface 'wan'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'
        option hostname 'cabin-firewall'
        option device 'eth0.2'
        option ipv6 'off'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '64:09:80:7b:cc:88'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

root@cabin:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option txpower '20'
        option country '00'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option country '00'
        option cell_density '0'
        option txpower '20'
        option legacy_rates '1'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2'
        option key ''
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2'
        option key ''
        option network 'lan'

Solved it. Wi-fi country cannot be left as 00-Global. Needs to be set to a country. Is this a bug??

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.