Miui R4AC / 4A Gigabit WDS Bridging

Hello,

I have an Miui R4AC / 4A Gigabit router with official Chinese firmware installed.

What I have done:

  1. I have setup the router as Wireless bridge.
  2. I have gained ssh access to my router using OpenWRTInvasion.
  3. Edited the /etc/config/wireless by adding option wds '1' in config wifi-iface section. File contents are below.
config wifi-device 'mt7612'
	option type 'mt7612'
	option vendor 'ralink'
	option channel '0'
	option bw '0'
	option autoch '2'
	option radio '1'
	option txpwr 'max'
	option hwband '5G'
	option hwmode '11ac'
	option disabled '0'
	option country 'CN'
	option region '1'
	option aregion '0'

config wifi-iface
	option device 'mt7612'
	option ifname 'wl0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Xiaomi_0B4C_5G'
	option encryption 'mixed-psk'
	option key '1234567890'
	option disabled '0'
	option macfilter 'disabled'

config wifi-device 'mt7628'
	option type 'mt7628'
	option vendor 'ralink'
	option channel '0'
	option bw '0'
	option autoch '2'
	option radio '1'
	option txpwr 'max'
	option hwband '2_4G'
	option hwmode '11ng'
	option disabled '0'
	option country 'CN'
	option region '1'
	option aregion '0'

config wifi-iface
	option device 'mt7628'
	option ifname 'wl1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Xiaomi_0B4C'
	option encryption 'mixed-psk'
	option key '1234567890'
	option disabled '0'
	option macfilter 'disabled'

config wifi-iface 'minet_ready'
	option disabled '0'
	option device 'mt7628'
	option ifname 'wl2'
	option network 'ready'
	option mode 'ap'
	option ssid 'minet_ready'
	option hidden '1'
	option encryption 'none'
	option dynbcn '1'

config wifi-iface 'guest_2G'
	option disabled '1'
	option device 'mt7628'
	option ifname 'wl3'
	option network 'guest'
	option mode 'ap'
	option wpsdevicename 'XIAOMI_ROUTER_GUEST'

config wifi-iface
	option ifname 'apclii0'
	option network 'lan'
	option encryption 'WPA2PSK'
	option device 'mt7612'
	option enctype 'AES'
	option scanifname 'wl0'
	option apcliband '5g'
	option key '1234567890'
	option mode 'sta'
	option wds '1'
	option disabled '0'
	option ssid 'GOGLNTBS02'
  1. Here are the contents of /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option localise_queries '1'
	option rebind_protection '0'
	option rebind_localhost '1'
	option local '/lan/'
	option expandhosts '1'
	option nonegcache '1'
	option authoritative '1'
	option logqueries '0'
	option logdhcp '0'
	option allservers '1'
	option clearonreload '1'
	option cachesize '1000'
	option negttl '300'
	option maxttl '300'
	option maxcachettl '1800'
	option local_ttl '0'
	option dnsforwardmax '300'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option client_update_ddns '1'

config dhcp 'ready'
	option interface 'ready'
	option start '10'
	option limit '20'
	option leasetime '5m'
	option force '1'
	option ignore '1'
  1. My /etc/config/network configuration is as below.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option gateway '192.168.200.1'
	option mtu '1500'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option ipaddr '192.168.200.254'
	list ip6class 'ifb'

config interface 'ifb'
	option ifname 'ifb0'

config interface 'ready'
	option proto 'static'
	option ipaddr '169.254.29.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option proto 'dhcp'
	option mtu '1500'
	option ifname 'eth0.2'
	option auto '0'

config interface 'openvpn'
	option ifname 'tun0'
	option proto 'openvpn'

But still WDS is not working. May someone please help me in this regard?

Thanks.

Miui R4AC is 100M device. I installed with right Openwrt firmware and everything is working nicely now.