Missing WAN port in VLAN switch0 page(ASUS RT-AC58U)

Hi, I just flashed asus rt-ac58u, the ISP requires to set VLAN ID to 10, priority set to 0, why I can not see WAN port in the settings on 19.07 version, but 18.06 version works fine? physically eth0 is LAN, eth1 is WAN.

I want to see something like this:

BTW, can someone tell me how to set VLAN ID:10 and priority:0 in openwrt?

That looks like a big to me, you should report it. In the meantime, u would just edit the network config manually.

The same issue exists with the Fritzbox 4040 and probably any other IPQ40xx based device.
More details here: https://forum.openwrt.org/t/ipq40xx-switch-config-strangeness/


after 3 days painful and hard work I finally successfully make my asus ac58u connect to internet, now all WAN,LAN and wireless work perfectly at v19.07.2. I find v19.07.2 and v18.06's configuration file are totally different. Anyway, never trust and use luci to config VLAN, only edit /etc/config/network file, below is my final config file:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fdff:ce9a:c40f::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'
	option ifname 'eth0'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1.10'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'eth1.10'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '10'
	option vid '10'
	option ports '0t 5t'

Thanks all for your help, I learned a lot as a newbie.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.