Missing /usr/lib/rsyslog/lmnsd_gnutls.so

I have noticed that rsyslog package out of the box doesn't support tls (encrypted transmission of logs).
Running manually /usr/sbin/rsyslogd -n spotted below:

root@firewall-box:~# /usr/sbin/rsyslogd -n
rsyslogd: could not load module '/usr/lib/rsyslog/lmnsd_gtls.so', dlopen: Error loading shared library /usr/lib/rsyslog/lmnsd_gtls.so: No such file or directory  [v8.18.0 try http://www.rsyslog.com/e/2066 ]

# I have following packages installed:
opkg list-installed |  egrep "gnutls|rsyslog"
gnutls-utils - 3.5.16-1
libgnutls - 3.5.16-1
rsyslog - 8.18.0-1

# Can somebody advise why gtls driver not included?

Ran into the exact same issue. @tomce did you find you a solution to this? So I was trying to ship the logs to Sumologic and it supports syslog only over TLS.

It appears both syslog-ng and rsyslog on OpenWRT is compiled without TLS support. :frowning:

Why dont you add a config option to compile with TLS then?

1 Like

My apologies, syslog-ng does work over TLS on OpenWRT. It was a config error on my side which was causing it to not work earlier.

So it's just rsyslog which doesn't have TLS support on OpenWRT, syslog-ng is compiled with TLS support.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.