Missing "switch" menu item under "network"? (trying to setup MultiWAN)

Ok, so I am trying to follow some youtube video to learn how to configure MultiWAN. But why I don't have "Switch" menu item under my Network?

br-lan was configured to bridge both LAN1 LAN2, but I read somewhere they say that may be the cause? So I remove the bridge, but still no "swtich" showing. I've looked at LUCI package, I don't see any association to this "switch" page either.

I am trying to do a failover between my Cellular WAN connection and a ISP connection which would go to one of the LAN port.

Any idea? Thank you for the help!

Your firmware is quite old but:

Ok, thank you I will. Actually that is my next project. I need to figure out how to take my "current" change and do a recompile to the new 23.xx. Someone did this firmware for us. Hopefully is not too hard to recompile my 22.xxx to 23.xx

BusyBox v1.35.0 (2023-04-27 20:28:15 UTC) built-in shell (ash)


| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
|
_____|| |
||||___||| |____|
|
| W I R E L E S S F R E E D O M

OpenWrt 22.03.5, r20134-5f15225c1e

root@OpenWrt:~# ubus call system board

{
        "kernel": "5.10.176",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "custom Router",
        "board_name": "custom,custom-router",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.5",
                "revision": "r20134-5f15225c1e",
                "target": "ramips/mt7621",
                "description": "OpenWrt 22.03.5 r20134-5f15225c1e"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd89:c2a4:5db5::/48'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.10.4.200'

config interface 'LTE'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option pppdev '/dev/ttyUSB3'
        option sim 'sim1'
        option auth1 'none'
        option pdptype1 'ipv4'
        option auth2 'none'
        option pdptype2 'ipv4'
        option dialnumber '*99#'
        option operatorlock '0'
        option mtu '1428'

config device
        option name 'lan1'

config device
        option name 'lan2_wan'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'router_wifi_2600E0'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'router_wifi_2600E1_5G'
        option encryption 'none'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option logqueries '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall

Maybe they neglected to configure the ports beyond what was needed. A typical thing to do to ensure a customer must come back for maintenance/upgrades.

Please click on configure for lan1 and lan2 and post the screenshot remember to redact MACs or anything else personal.

Someone else will need to help with that..

You mean you are not sure (because of that system) why missing "switch"? I do know our router uses MediaTek MT7621 and when compile it uses files under this folder:
image

And also, are you saying that because something is not correct on the "configuration" file which would cause OpenWRT to "not show" the "switch" menu item?

What I mean is that, normally, the system board call tells us what the brand and model the device is and the fact that only eth0 shows up in devices means the firmware is so old I don't remember where the configurations for switches are or they are not compiled in the build.

Someone else will clear all this up.

ok, ya, this is a custom router we build. Is not like of the shelve netgear or tplink or somthing like that.

Our router currently uses Advanced Tomato and we want to port over to OpenWRT

swconfig driver for MT7621 that shows "switch" configuration under "network" on LuCI was obsoleted and switched to DSA driver.

see details:

https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial

Hello Musashino,

thank you so much for the information! So, if you don't mind, 2 question:

  1. Where is this page? I don't see it..

  2. The reason I start asking about "switch" is because I want to learn how to use MutliWAN where I can do failover between 2 WAN internet feed. But 2 of the youtube video tutorial that teach they all use "switch". So if there is no "switch" in my module, how can I use MultiWAN or am out out of luck?

Here are the interface I have

How can I "link" the physical interface to these weird "wan, wan6, blah"?

do you know and link or url to how to use MultiWAN Luci interface?

Thank you!