Missing packages for arm_cortex-a9_vfpv3

While I am trying to use iptables statistic module, the iptables-mod-ipopt installation is failed
the Error message looks like

Collected errors:

  • Satisfy_dependencies_for: Cannot satisfy the following dependencies for iptables-mod-ipopt:
  • kmod-ipt-ipopt *

tried installation of kmod-ipt-ipopt manually, the result is "Unknown package kmod-ipt-ipot",
Look through the download repo, it sounds like most kmod* are missing, wish it could be corrected soon


The repo I am using is the 17.01 release, I don't know how long it might take to wait
I have go through the downloads server, under base directory, there is no kmod*.ipk files......

[quote="bigboyq, post:1, topic:2454"]
tried installation of kmod-ipt-ipopt manually, the result is "Unknown package kmod-ipt-ipot",
[/quote]You made a typo either when issuing the opkg command or when writing your message, as it says there "kmod-ipt-ipot".

Have you done "opkg update" first, to update the package lists?

Kernel modules are stored in the targets download section, not packages. Opkg should point the correct link to the repo. Are you using the official build, or somebody's private build that has abnormal opkg config?

arm_cortex-a9_vfpv3 is used by "mvebu" target platform. Let's look there...

Direct link to the 17.01.0 kmod-ipt-ipopt package for mvebu:

May be it due to my configuration errors?
From my distribution Feeds, I can found

[details=Summary]src/gz reboot_core hxxp://downloads.lede-project.org/releases/packages-17.01/arm_cortex-a9_vfpv3/packages
src/gz reboot_base hxxp://downloads.lede-project.org/releases/packages-17.01/arm_cortex-a9_vfpv3/base
src/gz reboot_luci hxxp://downloads.lede-project.org/releases/packages-17.01/arm_cortex-a9_vfpv3/luci
src/gz reboot_packages hxxp://downloads.lede-project.org/releases/packages-17.01/arm_cortex-a9_vfpv3/packages
src/gz reboot_routing hxxp://downloads.lede-project.org/releases/packages-17.01/arm_cortex-a9_vfpv3/routing
src/gz reboot_telephony hxxp://downloads.lede-project.org/releases/packages-17.01/arm_cortex-a9_vfpv3/telephony[/details]
No targets definition, May be I have made mistakes.....

After manually adding line
src/gz reboot_targets http://downloads.lede-project.org/releases/17.01/targets/mvebu/generic/packages

it works correctly, not sure it is bug or my fault made earlier, thanks for your attention.

Another question by my friend who is using EA4500, which is related to arm_xscale
There is no openconnect package, don't know why....

I have exactly the same problem, it is just missing in http://downloads.lede-project.org/snapshots/packages/mips_24kc/packages/

This is my first try of snapshots (as another package seems to be broken in the stable release). Am I just too fast and the buildbot is not done yet? If so, where can I check this?

It is indeed available in the 17.01 release (mips_24kc)

The package fails to compile in the buildbot:

Might be just due to missing dependencies in the Makefile:

Package openconnect is missing dependencies for the following libraries: