Missing openvpn-openssl package?

opgk update works
Can't install openvpn see error :

root@OpenWrt:~# opkg install openvpn-openssl
Unknown package 'openvpn-openssl'.
Collected errors:
 * opkg_install_cmd: Cannot install package openvpn-openssl.


Which version of OpenWrt firmware, and which date was it created?

(You can look at the creation dates in /etc/ with ls -l /etc/ to tell when it was created, ignoring the 1969/1970 ones)

Gl-inet MT300N-v2
Openwrt: 18.06.2
Date: Thu Jan 31 02:55:15 2019
sha256sum: bc3b2bf6a142ddb985d01685bb2ca8477aff6ad3aabafd214927df1a634f8565

P.S. Downgraded to 18.06.1, openvpn-openssl missing too :dizzy_face:
Yesterday worked , today not working !?!

Did you run opkg update before opkg install?

of course !

http://downloads.openwrt.org/releases/18.06.2/packages/mipsel_24kc/base/ is indeed currently empty. The buildbot shows a "failed updatefeeds" error. I'm not deeply familiar with the build process, but to me it looks like a glitch and not a build failure.

Maybe wait for the next build cycle (tomorrow?), and if it still doesn't build the packages let's alert a dev member since mipsel_24kc is a rather popular target architecture. (I'm guessing dev members will watch the build process very closely tomorrow anyway, 18.06.3 will be tagged and start to build.)

That's only natural. Packages (not depending on kernel) are common across all 18.06.x releases.

1 Like

fwiw, seems to be same problem earlier this week.



Thank You
Why opkg update doesn't tell state of repository ?

It tells you what's there, but, you're right, it doesn't tell you what isn't there.

If you're curious about what "should" be there https://openwrt.org/packages/start has package tables linked, as well as being able to download a CSV "database".

OpenVPN is still missing.

same here on my GL-MT300N-V2

any workaround avalible ?

No, there's no workaround (edit: at least not an easy one). 18.06.3 is being built right now, and the packages alongside with it. If all goes well, the packages will be back in a few hours.

the same here Zbtlink ZBT-WR8305RT :sleepy::sleepy::sleepy:

same on my MiWifi 3G.
luci-app-openvpn available, but "openvpn-* " and "ip-full" packages not found.

To delete a working set of packages BEFORE building the new ones seems stupid...
How to alert devs of this failure ?

That is not what happened. On June 20, the build process failed partially, producing a "base" directory with zero packages (but still a package index that is also zero). This was uploaded, as it should have.

However, subsequent builds after June 20 failed completely. The whole packages directory was not updated in that time, which left the "base" directory in its broken state.

Today's build finally went through again. As of now it hasn't been uploaded to the server yet, so that's something to keep an eye on.

1 Like

now 5:52 pm CEST it works !!:grinning::grinning::grinning: