Missing kmod-dwmac-intel makes imagebuilder fail

My custom buildbot imagebuilder is not able to build X86_64 image anymore. Kernel module kmod-dwmac-intel is in included in imagebuilder default profile but this kmod is missing from latest repos
https://downloads.openwrt.org/snapshots/targets/x86/64/kmods/5.15.141-1-e8cffc6420c207ac2a49281ac6f91ef1/ and previous one.

Unknown package 'kmod-dwmac-intel'.
...
Collected errors:
 * opkg_install_cmd: Cannot install package kmod-dwmac-intel.
make[2]: *** [Makefile:189: package_install] Error 255
make[1]: *** [Makefile:144: _call_image] Error 2
make: *** [Makefile:262: image] Error 2
cp: cannot stat '/mnt/Share/Configurations/OpenWRT/Build/Images/openwrt-x86-64-generic-squashfs-combined-efi.img.gz': No such file or directory```
1 Like

Related ?

Yeah I've seen this commit and yes this is surely related. Last time my buildbot compiled the image properly is Nov 27th.

I'm getting the same error from imagebuilder on x86 generic snapshot today.
Looks like it's been missing since the change to 6.6 kernel

1 Like

Opened new bug

that's not really the proper problem description though ...

there's nothing wrong with the image builder, there's a package missing, that's the issue.

We have faith that the devs will be smart enough to work out the issue

x86/64 imagebuilder broken, probably related to passage to 6.6 Kernel made in commit 15370.
kmod-dwmac-intel is default but this module is not in current kmods snapshot repo.

Please tell me what's wrong in this desciption...

And by the way, last time that happen the solution wasn't not adding this package but to remove the dependency itself. So no it's no only a matter of missing package.

it's not IB that's broken ?

There is a difference between the cause and the issue.

Is there a fix for this ? i tried todays snapshot image builder and i get the same error.

I have merged the patch for this, though it will take some time until buildbots catch up:

2 Likes

Thank you @robimarko