Missing 2.4GHz Radio - Afoundry EW1200

Not unless you rebuild the firmware with that package included at the moment. I'll check tomorrow if the build settings for your device need fixing in master and send in a patch if necessary, if someone didn't beat me to it.

The kmod-mt7603 isn't included, indeed, in the ew1200 profile in sources.
Don't know where to ask for!

Thanks Borromini, I'm pretty interessted for it too!

I've a patch in my staging tree to add kmod-mt7603 to the image. I'm doing some build tests and will push it later to the lede repo.

Thanks @mkresin
Any idea when i'll be able to download it ?

Is there any way to rebuild same firmware and add driver + LUCI easily ?

I'm assuming that this got broken by the following commit:
https://github.com/lede-project/source/commit/d17cb4a68a4544dca690629ee9a2483da29fa42a

You can use the image builder to repackage the 17.01.2 binary with kmod-mt7603 in it.

Nope, it was broken from the beginning. This commit added at least the driver for the 5GHz wireless.

New images should be available within the next 12h. Check the mt7621 build status in http://phase1.builds.lede-project.org/grid.

Support for the ew1200 is only in master. But beside that Borromini is right. Use the image build to build an image with the packages of your choice included.

Last night i've downloaded the SysUpgrade, Everything works well.
I've try to make my own image too, i've luci and theme Working Well on reset :slight_smile:

Thanks Everybody !!

@benda95280 it's possible to contact me ? I'm French user of EW1200 and need to install LEDE but don't have the UART USB interface...

Hey,
I'm French Too :slight_smile:

I wasn't having UART USB Interface, i've used my arduino ... Work Well !
But you need an interface ... Without it, impossible.

Hey there! I've installed LEDE (presently snapshot r5388-6fcf422) on my EW-1200. Many thanks to the folks who've ported it; LEDE is a huge improvement over the manufacturer's firmware.

It works great except for one thing: the 2.4Ghz wifi. I've followed the advice above and installed kmod-mt7603 (4.9.58+2017-11-16-8f1c8abd-1), but despite several reboots and fiddling with the settings for that device none of the wireless networks I configure on it are visible from other devices. Naturally I've checked using several to rule out the case that one's misbehaving.

Can anyone advise me on how to get it working? Without it I fear my wifi-enabled bathroom scales may never work again :frowning:

Some output in case it's useful:

root@gw:~# lsmod | grep mt7603
cfg80211              214676  5 rt2x00lib,mt76x2e,mt7603e,mt76,mac80211
mac80211              420160  6 rt2800lib,rt2x00usb,rt2x00lib,mt76x2e,mt7603e,mt76
mt76                   16047  2 mt76x2e,mt7603e
mt7603e                29980  0

root@gw:~# cat /etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
	option country 'GB'
	option channel '11'
	option txpower '17'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'MYSSID'
	option encryption 'psk2'
	option key 'MYPASSPHRASE'
	option wpa_disable_eapol_key_retries '1'
...

root@gw:~# iw phy0 info
Wiphy phy0
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	max # scan plans: 1
	max scan plan interval: -1
	max scan plan iterations: 0
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Available Antennas: TX 0 RX 0
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
	Band 1:
		Capabilities: 0x1fe
			HT20/HT40
			SM Power Save disabled
			RX Greenfield
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 4 usec (0x05)
		HT TX/RX MCS rate indexes supported: 0-15
		Frequencies:
			* 2412 MHz [1] (20.0 dBm)
			* 2417 MHz [2] (20.0 dBm)
			* 2422 MHz [3] (20.0 dBm)
			* 2427 MHz [4] (20.0 dBm)
			* 2432 MHz [5] (20.0 dBm)
			* 2437 MHz [6] (20.0 dBm)
			* 2442 MHz [7] (20.0 dBm)
			* 2447 MHz [8] (20.0 dBm)
			* 2452 MHz [9] (20.0 dBm)
			* 2457 MHz [10] (20.0 dBm)
			* 2462 MHz [11] (20.0 dBm)
			* 2467 MHz [12] (20.0 dBm)
			* 2472 MHz [13] (20.0 dBm)
			* 2484 MHz [14] (disabled)
	valid interface combinations:
		 * #{ IBSS } <= 1, #{ managed, AP, mesh point } <= 4,
		   total <= 4, #channels <= 1, STA/AP BI must match
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing

No problem for me, i haven't added mod-mt7603, correction have been done.

Hi @benda95280. The device had the same problem before I installed kmod-mt7603. The 2.4Ghz showed up and I could configure it, but none of its SSIDs were visible on other devices.

Based upon what you've said I did opkg remove kmod-mt7603 and rebooted. Now my 2.4Ghz device doesn't show up in iw list at all. Could it be that the files in /lib/modules and /lib/firmware have been removed and if so, is there a way to get them back without re-flashing my router?

If you want, you can try with my firmware Download

@benda95280 Awesome, I'll give that a try later. Thanks!

I've been delayed from replying because new accounts can't post more than three replies to a topic :frowning:

Gave your firmware it a try but the problem is the same. I've filed a bug report - let's see if this is happening for anyone else.

Hi,

With the last firmware for EW1200, 2.4 Ghz works for me, but sometimes the SSID doesn't show. Need to restart to works fine.

Alas I've tried many restarts, both of the EW1200 and connecting devices.

I wonder if Afoundry might have quietly revised the chipset - I bought mine in July last year, how about yours? I may have access to a more recent EW1200 in a couple of weeks time so I'll try flashing LEDE on that to see if it's any different.

In fact you don't need an interface. I figured it out long after I sent my patch to LEDE, and I don't remember the exact details, but in essence:
In the stock firmware, use the configuration backup menu. You'll download a file.
I think the file is gzipped (not quite sure about that). If so, then gunzip it.
Then open it with a text editor (one that doesn't screw up the unix-style new-line sequence)
In there, you can find a line about a telnet server, which is set to false. Well, set it to true, and re-upload that config file to the router (gzip it again if necessary).
Well, now your router will give you a shell prompt when you telnet to it. Easy. No need to open the device :slight_smile:
I'm probaby too late for your case, but wanted to leave this comment in the thread for other people who may want to do this later on.

I've just updated to the latest ew1200-squashfs-sysupgrade.bin but it's still the same - no matter how many times I reboot, no 2.4Ghz network shows up on any of my devices. Is anyone else seeing the same problem?