Mips_24kc packages missing since yesterday

Hi everyone,

I'm running a snapshot build on my Archer C2 v3 router. So I've to install manually the LuCI interface by a simple command as described on this webpage.

This evening I tried to install a package, it won't install so I decided to reset my router and reinstall the LuCI interface. But now I've found out the problem: someone has messed up the packages list for this architecture. All the packages have a new last modified date, check it out here.

Even worse is that the package to install LuCI interface is missing now and maybe many other packages too...

It's very sad, because now I can't use my router anymore with OpenWrt in combination with an interface. So annoying that anyone removed useful packages with a simple click, please help!

No bug, this is normal, snapshots are only available ~24 hours. For more details, see: https://openwrt.org/releases/snapshot

You must upgrade to the current snapshot and install all needed packages. Do not delay in installing your desired packages.

Also be sure to run opkg update before attempting to install packages, the list must also be refreshed within 24 hours.

2 Likes

Ok thank you, on my specific router page nothing was mentioned about a new snapshot build. I was already thinking about it but now I see there is a new snapshot build or whatever it's called.

Back up and running, pfiew!

This is factually wrong. Non-kmod packages, especially things like LuCI should be available indefinitely.

2 Likes

No, the packages just got rebuilt and updated on the download server.

The LuCI packages are in another directory: https://downloads.openwrt.org/snapshots/packages/mips_24kc/luci/

What likely happened is that LuCI got updated from 19.252.69963 to 19.254.43391 shortly after you installed your build. A simple opkg update should have solved the problem with the missing packages.

4 Likes

Unless the newer version is built. :wink:

In which case opkg update will fetch newer newer lists.

4 Likes