Miniupnp with igd2 not compatible with consoles

Exactly. Can't we at lease have the ability to choose which version we would like to have installed? The idea with two separate packages sounds sane to me. Second package with idg1 seems to be a valid solution.

1 Like

Again, don't be lazy and report this to your vendor. You clearly have the ability to choose version.

Marbi, thank you for the package, much appreciated. Out of curiosity, how difficult is it to compile packages?

While I have experience with Linux, I've never had to compile anything I've always just installed packages or upgraded packages.

Thanks again!

  1. Download Debian image for VMware or Virtualbox. For example from here.
  2. Be sure that all needed packages are available:
    sudo apt-get install build-essential libncurses5-dev gawk git subversion libssl-dev gettext unzip zlib1g-dev file python
  3. Make a directory and download source:
    mkdir /lede && cd /lede && git clone .
  4. Change to release branch, lede-17.01 in this example:
    git checkout lede-17.01
  5. Download and install additional feeds:
    ./scripts/feeds update -a && ./scripts/feeds install -a
  6. Check if you have required dependencies installed:
    make defconfig && make prereq
  7. Configure LEDE by selecting your target system and profile, and activate miniupnpd package as module:
    make menuconfig

  8. Remove igdv2 patch from patches directory of miniupnpd (for lede-17.01 only, master branch has an option to compile with igdv2)
    rm ./feeds/routing/miniupnpd/patches/106-enable_igdv2.patch
  9. Compile all stuff:
    make tools/install && make toolchain/install && make package/miniupnpd/compile
  10. Package will be available at:

Thanks for the tutorial, seems pretty straightforward. I'll give it a try.

Again, thank you for your help!


I've managed to follow the rest of the compiling guide using Ubuntu 17.04[quote="marbi, post:24, topic:2016"]
make tools/install && make toolchain/install && make package/miniupnpd/compile

After typing the make tools/install && make toolchain/install && make package/miniupnpd/compile
I receive this error message

make -r tools/install: build failed. Please re-run make with -j1 V=s to see what's going on /lede/source/include/ recipe for target 'tools/install' failed make: *** [tools/install] Error 1

I also ran '-j1 V=s' in the command and this is the output

Can someone shed some light on this please

Many thanks


configure: error: you should not run configure as root (set FORCE_UNSAFE_CONFIGURE=1 in environment to bypass this check)

You need to run everything as a normal user instead of root, or set the flag mentioned before running configure.

Does set FORCE_UNSAFE_CONFIGURE=1 go before the other command like this?:-
set FORCE_UNSAFE_CONFIGURE=1 make tools/install && make toolchain/install && make package/miniupnpd/compile

I was having the same problem, when logged in as a standard user it would fail to compile due to permissions on the "lede" directory and all sub-directories. Even when I used SU in terminal and then used set FORCE_UNSAFE_CONFIGURE=1 it would still fail to compile. When I checked the permissions on the "lede" directory the owner was "root". What I did was change the permissions on the "lede" directory and sub-directories so the owner was the standard login. Once I did that I was able to compile the package without any errors as a standard user without using set FORCE_UNSAFE_CONFIGURE and it installed fine. Don't know if when I was configuring everything initially the permissions were applied incorrectly to the directory or if changing the owner was the best way to accomplish compiling the package but it worked.

1 Like

Thanks for all the info
I have compiled myself and now it's working perfect with my PS3
Heres the link to my comiled package of miniupnpd IGDv01 for ar7xx TL-WDR4300-v1 lede 17.01

Hey there, I'm having some issues compiling this myself (I don't think my pc is strong enough to be a build environment). Can someone compile this for me for the R7800? Thank you.

Edit We are good to go now. I got the file compiled and uploaded to my router. Thanks!

1 Like

Also having problems compiling on my own. Can someone kindly compile 2.0.20170421-1 for the Marvell Armada/WRT series (using WRT1200AC)? TIA

@cvill Here is the link to the file I compiled for you. It is the 2016 one that I stated above, this has the IGDv2 patch removed and will work for the console issues that were stated above.!nEpzWRLK!Ig1pFkJf6CJGQKR9tBqCsf5pk6t8zVBRIlvp6r6QEAw

I've just spent several hours trying to figure out how to compile this on Debian, and all i got was to terminal and osboxes@osboxes sudo error. just want this to work effortlessly like the stock image upnp to work for PS4 open NAT. Anyone have it compiled for the Netgear 7500v2 arm_cortex-a15_neon-vfpv4 architecture?

I installed a fresh install of Debian, sure it took a little longer than using an already setup image, but it works.

Since I'm a nice guy here is a link to the one I made for my R7800, works great for my multiple Xbox One consoles.!rd5AyTjL!v49hyO2uTkwfSB05hs3ENiCgDbjrxP2T6l6eqrRNrXA

1 Like

Thanks man really appreciate it. I would love to be able to do this my own as well, if u don't mind me asking a second favor, coming from a noob asking this, any links or video tutorials on how to do this, to get me started for later down the road? Because I don't just want to NOT know how to so this for future tweaks.

Honestly man, you need to look up how to setup a virtual machine first. If you downloaded and set up virtualbox, you've started off great. What you need to do next is to download the iso of the distro you wish. Most here use Debian from what I can tell. Download that and install it into your VM. There you go.

I would really read and watch youtube videos on how to do this. Don't flash anything to your router until you are 100% sure that you won't break something. Also, you did read up on how to install an ipk file right?

@mrmidnight Since i dont have the time, any chance that you can support the package for the original repo? Like autobuild the package for legacy support?

@bigfat I'm still new at this kind of stuff myself. I don't know how to build out of the original miniupnpd repo to support legacy clients. If someone else here could help me then I would be able to.

1 Like