Minidlna not finding files

Hey there,

I have OpenWRT 18.06 installed on a Linksys Wrt1200ac and a minidlna running. It is pointed towards media folders (audio and video) on a mounted drive. minidlna is (apprently by default) running as root, the permission on all media folders is 1000:users with r+w access.

However, minidlna only shows up 304 audio files and no video files. The 304 audio files could correspond to the toplevel files. /var/log/minidlna.log does not show any glaring errors..

Has somebody come across this before? Could this be a permission issue?

Thanks guys

edit: I have seen this: miniDLNA not finding video files and have libffmpeg-mini installed...

It's most likely because libffmpeg-mini doesn't recognize your video files. I'm not sure if you just can replace custom with libffmpeg-full of if you also need to recompile minidlna.

I would have thought the permissions should be r+x. Have you tried changing permissions?

Nope, that's not it. Here are the permissions:

drwxrwxrwx   34 1000     users         4096 Oct 16 16:57 movies
drwxrwxrwx  280 1000     users        16384 Sep 24 16:48 music
drwxrwxrwx   15 1000     users         4096 Dec  9 18:07 series

And inside the folder:

drwxrwxrwx    2 1000     users         4096 Aug 27 14:07 XXX
drwxrwxrwx    5 1000     users         4096 Sep  5 19:51 YYY
drwxrwxrwx    2 1000     users         4096 Aug 27 12:38 ZZZ

etc.

While I haven't specificly tried minidlna even though I doubt see why it wouldn't work I do have a variant of ffmpeg in my repo that's hardcoded and handles "most" media formats out of the box.

Because it includes a few libraries such as fdk-aac it cannot be distributed in binary form.

I've mainly tested this on ARM and it works fine for me (tm).
This version also works with the newest release of fdk-aac :slight_smile:

This is kind of a longshot because the 1200 has plenty of memory, but if you have a large collection of music/movies the 1200 might run out of memory and stop while making the original inventory, to get around that you can make a folder on your mounted drive and in Luci go to Services>Minidlna>Advanced Settings and point your Database directory and Log directory to that folder.

1 Like

Thanks Mike, but that is not the problem. Tried your workaround, didn't work.

okay, I found the problem - basically by accident: although I can add several folders without minidlna throwing any errors, minidlna only shows the contents of the first folder specified. This is kind of weird. putting my "series" folder into my "movies" folder kind of solves the problem for me

I recently tried minidlna pointing on a cifs mounted over a vpn connection. At first I installed my project on openwrt x86 on my laptop and minidlna showed all directory and subdirectories content. After I reinstalled on a router using 18.06.4 target brcm63xx and I noticed your issue: subfolders aren't shown. Perhaps is a compiling issue of minidlna or of some dependencies?