Mikrotik SXTsq 5 ac (IPQ40XX)

That one is quite expesive, but for the specs it is understandable :slight_smile: it seems like a good SBC server

Problem with this sxtsq 5 ac is that it seems ultrasonic welded, not sure how to confirm that without breaking everything. I doubt that it does not have a serial port somewhere in there

It most likely like every other Mikrotik device have serial header on the board but it is disabled by the bootloader

btw, what do you mean with

Well, off course you dont get any connectivity as nothing is configured

Do you mean configured on owrt? if so it might be possible to configure before compilation, no?

Also, here it says that

When rebooting a RouterBoard the bootloader (RouterBOOT) will always use the serial console (serial0 on RouterBoards) to send out some startup messages and offer access to the RouterBOOT menu.

So at least the bootloader outputs to the serial port on every routerboard devices (read all mikrotik devices)

Off course you have to preconfigure everything.

That is taken from the Wiki and it is not correct at all.
I can guarantee you that UART does not work on any never(As in 1-2 years old) device that does not adverise UART

sorry to bother again, is there any news on this?

Here some more info to better understand the device

Internal Photos

External Photos (maybe where to open it)

The serial console is most likely disabled by default

Some old notes how to enable it

Uses same pintout (RX, TX, GND) ?

Thanks, i tried to search for the fcc id but found nothing :confused:

There does not seem to be an easy way to open it (without breaking), any thoughts on how to open it?

Yes, don't seem easy however

From the internal and external pictures, the actual mainboard is small, only as big as the four inner holes on the back (external picture)?

Maybe to outer small holes on back of the outer picture is where one would need to drill ? and them pry it open

Also looking at how one install OpenWRT on the Cisco Meraki MR33, ubootwrite is used over serial port (not sure yet if this method could help since the serial port still need be enabled)

any news on this?

Not from me, i gave up since with the current hardware i have i need to break the case thus breaking it's waterproofing (unless the waterproofing is just a protection on the pcb itself, no idea) :frowning:

I have test on my rb450gx4 (routeros v6.42.7), and I use https://github.com/0ki/mikrotik-tools to get the temporary root shell, here is some useful system info:

# cat /proc/cpuinfo 
Processor	: ARMv7 Processor rev 5 (v7l)
processor	: 0
BogoMIPS	: 1430.32

processor	: 1
BogoMIPS	: 1430.32

processor	: 2
BogoMIPS	: 1430.32

processor	: 3
BogoMIPS	: 1430.32

Features	: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xc07
CPU revision	: 5

Hardware	: Qualcomm (Flattened Device Tree)
Revision	: 0000
Serial		: 0000000000000000

# cat /proc/mtd 
dev:    size   erasesize  name
mtd0: 00800000 00040000 "RouterBoard NAND 1 Boot"
mtd1: 1f800000 00040000 "RouterBoard NAND 1 Main"
mtd2: 00040000 00001000 "RouterBoot"

# uname -an
Linux MikroTik 3.3.5 #1 SMP Fri Aug 10 13:35:23 UTC 2018 armv7l unknown

#  cat /proc/version 
Linux version 3.3.5 (build@builder) (gcc version 4.8.2 (GCC) ) #1 SMP Fri Aug 10 13:35:23 UTC 2018

# cat /proc/mounts 
rootfs / rootfs rw 0 0
proc /proc proc rw,relatime 0 0
tmpfs /ram tmpfs rw,relatime 0 0
devtmpfs /dev devtmpfs rw,relatime,size=509112k,nr_inodes=127278,mode=755 0 0
ubi1:RouterOS /flash ubifs rw,noatime 0 0
ubi0:Kernel /flash/boot ubifs rw,noatime,compr=none 0 0
5:4096 / squashfs ro,relatime 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
sysfs /sys sysfs rw,relatime 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
proc /ram/netns/main proc rw,relatime 0 0
5:4096 /ram/disk1 squashfs ro,relatime 0 0
5:4096 /ram/disk2 squashfs ro,relatime 0 0
5:4096 /ram/pckg/option squashfs ro,relatime 0 0
/dev/mmcblk0p1 /ram/disk2 ext3 rw,relatime,errors=continue,barrier=1,data=writeback 0 0

# cat /proc/meminfo 
MemTotal:        1018512 kB
MemFree:          964068 kB
Buffers:              12 kB
Cached:            25776 kB
SwapCached:            0 kB
Active:             6432 kB
Inactive:          22996 kB
Active(anon):       3712 kB
Inactive(anon):      104 kB
Active(file):       2720 kB
Inactive(file):    22892 kB
Unevictable:           0 kB
Mlocked:               0 kB
SwapTotal:             0 kB
SwapFree:              0 kB
Dirty:                 0 kB
Writeback:             0 kB
AnonPages:          3700 kB
Mapped:             4808 kB
Shmem:               164 kB
Slab:              11664 kB
SReclaimable:       1692 kB
SUnreclaim:         9972 kB
KernelStack:         616 kB
PageTables:          352 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:      509256 kB
Committed_AS:       8044 kB
VmallocTotal:    1024000 kB
VmallocUsed:       10072 kB
VmallocChunk:     878776 kB

And I just need a netboot kernel file such as lede-ipq4019-mikrotik-vmlinux-initramfs.elf, (I see the master branch has ready support the ipq40xx), is there any guide line to build the netboot kernel file?

So it seems like there is another mikrotik router supported by owrt (by @robimarko MikroTik rb450gx4 support ), would it be possible to port to this one?

Not sure about what dts is, but it seems to be needed, where to get that?

(really want to know progress on this one)

Any news on this one? Can i help in some way with my device? i tried the mikrotik tools exploit, but i guess that my firmware version was already patched, and the usb exploit is impossible to execute. Is it possible to downgrade the mikrotik firmware?

It should be possible to force a downgrade of the Mikrotik firmware


Have you been following the busybox tool method thread progress?

The SXTsq 5 ac does not have a sd card slot or usb port (at least, not exposed). I'll try to downgrade and then i'll give feedback

Turns out that downgrade through the official firmware is a dead end, it won't let me downgrade further than 6.41.3.

I can't plug a usb device nor a sd card on the ap without breaking the case :confused:

Any news on this one?

only this

Almost there, only the correct Ethernet configuration is missing.