Mikrotik RB941-2nD-TC problem while sysupgrade

I try to install latest (19.07.03) version on RB941-2nD-TC.
When I flash initramfs-kernel.bin it runs perfectly from RAM. But when I try sysupgrade with squashfs-sysupgrade.bin (with console or LuCI) it doesn't work.
With LuCI flashing stops on "Verifying image" step.
With console flashing stops immediately with "Killed" sign.
Looks like there is not enough ram/flash memory, but some people flash it successfully.
What did I do wrong?

P.S. I also tried previous firmware versions but with same result.

When running the initramfs, execute free and post the output here.

Right after flashing initramfs.bin:

root@OpenWrt:/# free
              total        used        free      shared  buff/cache   available
Mem:          26932        9644        6552          68       10736       14988
Swap:             0           0           0

After transfering sysupgrade.bin (I do that with pscp):

root@OpenWrt:/tmp# free
              total        used        free      shared  buff/cache   available
Mem:          26932        9696        2336        4232       14900       10780
Swap:             0           0           0

Sysupgrade log:

root@OpenWrt:/tmp# sysupgrade -n openwrt-19.07.3-ar71xx-mikrotik-rb-nor-flash-16
M-squashfs-sysupgrade.bin
Commencing upgrade. Closing all shell sessions.
Killed

19.07 version doesn't like 32MB ram devices.

1 Like

Thanks. I have installed 18.6.3 and it works!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.