Mikrotik RB750gr3

Howdy folks-

longtime OpenWRT user here. I have an odd situation I haven't encountered before. I flashed OpenWRT without any problems this last Jan on a RB750gr3, and was able to compile my own image version and get that on it as well. Just recently, I've done a git pull and recompiled. When I go to upload the image, I have the following error kick out:

Device mikrotik,routerboard-750gr3 not supported by this image Supported devices: mikrotik,rb750gr3 Image check failed.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Well, I YOLO'd and force pushed it. The device beeps, but then there is no more life. I soldered on a serial debugger to see what was going on. I use to get full serial access, but all I get in the output now is:

OpenWrt kernel loader for MIPS based SoC
Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
Decompressing kernel... done!
Starting kernel at 80001000...

So thinking that my latest firmware build is botched due to a change in the code for this platform but am unable to figure out what changed. My next debug step was to download the most recent OpenWRT build from the reference in the page for the hardware. https://openwrt.org/toh/mikrotik/mikrotik_rb750gr3

I go to upload the official OpenWRT firmware, and I have the exact same error message pop up. Before I brick another device, does anyone have any thoughts as to what's going on?

I have a JTAG debugger in the mail so that I can do more digging on the system.


@keyboardgnome, welcome to the commnity!

Are you saying that you previously got a different output on the serial port (e.g. RouterBoot OS)?

It use to boot and show the boot process and drop you into a shell. It doesn't show a boot process or drop into a shell. It just shows that message and nothing else happens.


I'm going to JTAG it this week.

OpenWRT image has now bricked one, where the previous install process worked just fine.