Mikrotik RB492AH success


#1

Just wanted to drop a note that I'm successfully running Jan1 snapshot of mikrotik LEDE firmware where as OpenWRT snaphshot did not work. The only issue I see is that only 5 switch ports are configurable through LuCi (IC+178C switch chip/9 eth ports).


#2

Was this a LuCi only issue? I mean, the ports are configurable by /etc/config/network ?


#3

I have not tried to configure any vlans yet. Out of the box I had to swap eth1 with eth0 and add switch config (as per openwrt page, config below). All ports work (except, as I mentioned, LuCi is showing only 5) and I'm quite happy with the performance. Even though this router is only 10/100 it can download at 95Mbit while using SQM (A+ buffer bloat) with 80% CPU to spare - I guess it has hardware NAT enabled...

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd23:0841:73cf::/48'

config interface 'lan'
option ifname 'eth1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'

config interface 'wan6'
option ifname 'eth0'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4 5 6 7 8'