Mikrotik RB2011-UiAS-2HnD-IN LEDE wan problem

Hi, I completely removed RouterOS from RB2011-UiAS-2HnD-IN and install last LEDE image.
wiki.openwrt.org/toh/mikrotik/rb2011uias#how_to_remove_routeros_nad_install_openwrt

I have another TPLINK router, also with OpenWRT, that serves addresses from dhcp via /etc/ethers based on hardware MAC addresses.

I have some problems with WAN interface on my RB2011-UiAS-2HnD-IN, i can't get WAN IP address from TPLINK DHCP.

The strange thing is that all interfaces have the same MAC address, image below.

(image) -> preview.ibb.co/m98EZn/Zdj_cie_02_04_2018_01_40_12.jpg

Here is stock /etc/config/network

(image) -> image.ibb.co/jLa6fS/Screenshot_1.png

ifstatus wan

"up": false,
"pending": true
"available": true,
"autostart": true,
"dynamic": false,
"proto": dhcp,
"device":eth0.2,
"data": {}

I Try to connect the WAN cable to the ETH1 port

From ETH2 to ETH5 I get genercin IP

Anyone can help me with taht ?

This is normal.

Are both LANs 192.168.1.0/24???

stock "ip addr" from my RB2011

root@LEDE:/etc/config# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether e6:7c:8a:13:dd:0a brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e68d:8cff:fe15:df00/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether 12:8a:5a:13:dd:01 brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether ee:13:5a:11:dc:1c brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether e6:7c:8a:13:dd:0a brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd58:dbfe:bca7::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::e68d:8cff:fe15:df00/64 scope link
       valid_lft forever preferred_lft forever
6: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether e6:7c:8a:13:dd:0a brd ff:ff:ff:ff:ff:ff
7: eth0.3@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether e6:7c:8a:13:dd:0a brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e68d:8cff:fe15:df00/64 scope link
       valid_lft forever preferred_lft forever
8: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether e6:7c:8a:13:dd:0a brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e68d:8cff:fe15:df00/64 scope link
       valid_lft forever preferred_lft forever

So...that means you're not getting a WAN IP?

And, as I asked:

Meaning is your WAN on the MikroTIk (i.e. the LAN on the TP-Link) also 192.168.1.0/24? This is not in a config on your MikroTIk, you should know this.

You should post your /etc/config/network actually. Perhaps your switch ports are not properly configured.

Please describe (more clearly) what you mean by this statement.

Now I understand, yes, my TPLink /etc/config/network

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

Mikrotik /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
 
config globals 'globals'
        option ula_prefix 'fd58:dbfe:bca7::/48'
 
config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1 eth1'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
 
config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
 
config interface 'sfp'
        option ifname 'eth0.3'
        option proto 'none'
 
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
 
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'
 
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'
 
config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '6 0t'
 
config switch
        option name 'switch1'

Sure, when i connect cable from ETH2 to ETH5 i get

IP: 169.254.133.208
Subnet: 255.255.0.0

You will need to renumber you MicroTik LAN at some point, or you will not get connectivity to the Internet.

Can you ensure that swconfig is installed.

That's ok, my problem is WAN, not LAN on Mikrotik
I try to change it to 192.168.1.180 for now.

Yes, version 11

You have to change the 3rd octet, not the fourth, your CDIR is /24, thats a subnet mask of 255.255.255.0. You have to renumber the subnet to something other than 192.168.1.XXX/24.

Can you take a picture of the Switch page in LuCI?

Well, i change my LAN to 192.168.2.0 and now i can't connect to ssh

DHCP give me 192.168.2.208 but can't ssh to Mikrotik

I get Permission danied

Because you need to SSH into 192.168.2.XXX now (the IP of your router), you just renumbered its subnet!

And if you had SSH access, that means your LAN was working.

Time to troubleshoot the WAN now.

My IP is 192.168.2.208
Mask 255.255.255.0
Gate 192.168.2.0
DNS 192.168.2.0

I can't SSH as root to 192.168.2.0

How can I reset configuration ? Reset button not working for me, still have 192.168.2.0

0 is an invalid 4th octet on a /24 (mask 255.255.255.0) network!!!

When you RESET your router, make sure you do not number a /24 with 0 or 255...those are reserved as the NETWORK ADDRESS AND BROADCAST ADDRESSES, respectfully.

Ok, so how can i reset this device ? Reset button don't work for me, still have 192.168.2.0

Since your reset button doesn't work...and...if you cannot connect via the serial port, I'd suggest beginning with the TFTP process, reflashing, etc. from scratch.

I try this already, i get

daemon.info dnsmasq-dhcp[1073]: BOOTP(br-lan) 192.168.1.230 e6:7c:8a:13:dd:0a

and that's it, TPLink communicate with Mikrotik, led's blinking and nothing happen, 10 minutes later Mikrotik boot and still have 192.168.2.0

Can i get FailSafe mode on this device ?

That means your WAN on the MicroTik works!

If you means you did TFTP again and reflash...make sure that you do not keep default configs, since they are bad for LAN.

Unfortunately...failsafe requires serial access, as I recall.

I try ether boot, sending lede-XX.XX.X-ar71xx-mikrotik-vmlinux-initramfs-lzma.elf
but it's not working, i get

daemon.info dnsmasq-dhcp[1073]: BOOTP(br-lan) 192.168.1.230 e6:7c:8a:13:dd:0a

can't get

daemon.info dnsmasq-tftp[1073]: sent /tftpboot/lede-17.01.4-ar71xx-mikrotik-vmlinux-initramfs-lzma.elf to 192.168.1.230

somethig is not right

Perform all steps you used to boot LEDE on the router for the first time.

Once you boot the ELF, reflash the BIN, and do not save configs.

Ok i manage to solve my problem with Reflash.
Let's continue, this is my SwitchPage from LUCI

ifstaus wan

"up": false,
"pending": true
"available": true,
"autostart": true,
"dynamic": false,
"proto": dhcp,
"device":eth0.2,
"data": {}

OK.

  • Give the OpenWRT LAN a valid IP and mask (i.e. 192.168.22.1/24)
  • DO NOT MAKE THE THIRD OCTET ONE
  • DO NOT MAKE THE FOURTH OCTET ZERO
  • Reboot and browse to 192.168.22.1
  • Log back in and see if you have WAN connectivity

You shouldn't need to do anything fruther configs, this is what you want to see after reboot.