Mikrotik PPPoE Server, OpenWrt PPPoE Client Xiaomi AC2350

Greetings all.
I'm new to OpenWRT since finally my device listed at v21.02.2 firmware (Xiaomi MI AC2350).
My Router is Mikrotik RB4011iGS ROS 7.1.3, operating service for pppoe client that using Mikrotik hAP-AC3 ROS 7.1.3.
For AAA I use Mikrotik Radius with Userman v7.
Everything works fine, pppoe client connect with MPPE128 stateless encryption.

When I try to change the hAP-AC3 with Xiaomi Mi AC2350, openwrt installed and set to be pppoe client, there 'radius timeout' red error log at Mikrotik RB4011iGS (pppoe server).
Then I change AAA to not using Radius and Userman, so pppoe Server will use local data 'pppoe secret' for authentication of the user. With this Xiaomi AC2350 can connect to pppoe server BUT with no encyption.

My question are :

  1. How can I set OpenWRT Xiaomi AC2350 to communicate with Mikrotik Radius with Userman v7, so I can archieve my past state of connection (Mikrotik Radius AAA ON, Usermanager v7 ON, MPPE 128 stateless encryption ON).
  2. If can't use Mikrotik Radius and Usermanager v7 to work with, at least how can I set the Xiaomi AC2350 Openwrt pppoe client to connect to Mikrotik RB4011iGs with MPPE 128 stateless encryption ON.

Hope anyone can guide and enlighten me with answers. Thanks before.

My Mi AC2350 act as RADIUS CLIENT, while hAPAC3 act as RADIUS SERVER, PPPoE SERVER. Mi AC2350 have hostapd-common and wpad-basic-wolfssl
For RADIUS client, I remove wpad-basic-wolfssl and install (one by one, reboot and test) :

* wpad = got PPPoE link Error: Unknown error (AUTH_TOPEER_FAILED)
* wpad-wolfssl = same Error: Unknown error (AUTH_TOPEER_FAILED)
* wpad-openssl = same Error: Unknown error (AUTH_TOPEER_FAILED)

RADIUS secret and UserManager secret are exactly same.
PPPoE user name and password, both at UserManager and AC2350 PPPoE dialer are exactly same.

If I use Local Account for PPPoE (not using RADIUS/UserManager), same username and password, PPPoE link will be immidately connected and provide Internet.

Now confuse where should I look. Anyone?

Now after Mikrotik update to ROS v7.4 PPPoE via RADIUS can connect. The problem now is UserManager 'user' PPPoE client can connect to Mikrotik PPPoE Server but when limitation is reach (timed and or by data volume) the PPPoE connection still active. Not disconnect.

So the main problem is Mikrotik side. Thx. I close this thread.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.