MikroTik hEX RB750Gr3 boot issue

Hi everyone,

This is my first OpenWrt device and I decided to use my RB750Gr3 for this.
I used the tftp install method from : https://openwrt.org/toh/mikrotik/rb750gr3

This is the currently loaded image:

kernel: 5.4.154
hostname: MSProxy.local.domain
system: MediaTek MT7621 ver:1 eco:3
mode": MikroTik RouterBOARD 750Gr3
board_name: mikrotik,routerboard-750gr3
distribution: OpenWrt
version: 21.02.1
revision: r16325-88151b8303
target: ramips/mt7621
description: OpenWrt 21.02.1 r16325-88151b8303

I loaded the software using the tftp method.
I have loaded version 19 (all of them) and 20 (all of them), and all have the same outcome for me.
I have also tried different RouterOS versions and upgrading to OpenWrt from there in the hope that it might be related.

It unfortunately does not boot correctly.
When it tries to boot the usr light flashes on for 12 seconds and then off for 2 seconds continuously. When it does this it does not load. I have waited 2 hours, but nothing happens. I have also tried pulling the power and then booting up, same result. It was during the troubleshooting suggestions on the web that I saw the reset works.

I get it to boot up by pressing and holding the res button on the router. It will beep and then load up correctly.

It is working currently, but my ocd is triggered.... I cannot reboot without physically resetting the box.

I'm hoping it is something stupid I'm doing.
Please assist.

Problem solved! Thank you to u/Bradmck over at Reddit for the resolution. For anyone that has a newer version of this board: Load RouterOS 6.49.2 and then follow the install instructions on https://openwrt.org/toh/mikrotik/rb750gr3

All versions prior to this does not work (I only tried 7.1.1 after that version and it does not work either).

This worked for me and I hope that it will work for you

1 Like

Thank you for the feed back, I added it to the wiki page.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.