Mikrotik hap ac lite - 5ghz wifi disappear if not on ch36

recently i got another (tp-link archer) router that has only 4 channels to choose from, so i wanted to move the 5ghz wifi on the mikrotik from ch36 to, say, ch100 or upper.
problem is - once i do it - it will say "device not present" and 5ghz wifi won't work.
if i return it to ch36, reboot the router, then it starts working again.
i tried various channels from 48 up, it's always the same problem. it will "loose" 5ghz wifi.
i'm running openwrt 19 on it. i tried installing new drivers for atheros, they install OK, but still the same problem.

on stock routerOS wifi is OK but 5ghz is glitchy, it takes hours for phones and laptops to notice the network and connect to it, with openwrt i didn't have such problem, but only ch36 works.

thanks
PS i noticed now i posted in the wrong board. please some mod if can move the topic to "installing and using openwrt" sub-board.

i added 2 screenshots.
this is what the log say:

Mon Apr  5 19:19:28 2021 kern.warn kernel: [  240.487205] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Mon Apr  5 19:19:28 2021 kern.info kernel: [  240.501282] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Mon Apr  5 19:19:28 2021 kern.info kernel: [  240.508174] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Mon Apr  5 19:19:28 2021 kern.info kernel: [  240.516514] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 21576 iram: 11700'
Mon Apr  5 19:19:28 2021 kern.warn kernel: [  240.560325] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Mon Apr  5 19:19:28 2021 kern.info kernel: [  240.572188] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mon Apr  5 19:19:28 2021 daemon.notice hostapd: wlan0: INTERFACE-ENABLED
Mon Apr  5 19:19:28 2021 daemon.notice hostapd: wlan0: interface state DFS->DFS
Mon Apr  5 19:19:28 2021 daemon.notice hostapd: wlan0: DFS-CAC-START freq=5700 chan=140 sec_chan=0, width=0, seg0=0, seg1=0, cac_time=60s
Mon Apr  5 19:19:28 2021 daemon.err hostapd: DFS start_dfs_cac() failed, -1
Mon Apr  5 19:19:28 2021 daemon.notice hostapd: wlan0: INTERFACE-DISABLED
Mon Apr  5 19:19:28 2021 daemon.err hostapd: nl80211: Could not configure driver mode
Mon Apr  5 19:19:28 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mon Apr  5 19:19:28 2021 daemon.err hostapd: nl80211 driver initialization failed.
Mon Apr  5 19:19:28 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Mon Apr  5 19:19:28 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Apr  5 19:19:28 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Mon Apr  5 19:19:28 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Mon Apr  5 19:19:28 2021 daemon.notice netifd: radio0 (2254): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 2073 path ()
Mon Apr  5 19:19:28 2021 daemon.notice netifd: radio0 (2254): Device setup failed: HOSTAPD_START_FAILED
Mon Apr  5 19:19:39 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Mon Apr  5 19:19:40 2021 kern.warn kernel: [  252.660907] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Mon Apr  5 19:19:40 2021 kern.info kernel: [  252.677905] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Mon Apr  5 19:19:40 2021 kern.info kernel: [  252.684185] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Mon Apr  5 19:19:40 2021 kern.info kernel: [  252.692489] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 21576 iram: 11700'
Mon Apr  5 19:19:40 2021 kern.warn kernel: [  252.737453] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Mon Apr  5 19:19:40 2021 kern.info kernel: [  252.749633] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mon Apr  5 19:19:40 2021 daemon.notice hostapd: wlan0: INTERFACE-ENABLED
Mon Apr  5 19:19:40 2021 daemon.notice hostapd: wlan0: INTERFACE-DISABLED
Mon Apr  5 19:19:40 2021 daemon.err hostapd: nl80211: Could not configure driver mode
Mon Apr  5 19:19:40 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mon Apr  5 19:19:40 2021 daemon.err hostapd: nl80211 driver initialization failed.
Mon Apr  5 19:19:40 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Mon Apr  5 19:19:40 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Apr  5 19:19:40 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Mon Apr  5 19:19:40 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Mon Apr  5 19:19:40 2021 daemon.notice netifd: radio0 (2362): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 2073 path ()
Mon Apr  5 19:19:40 2021 daemon.notice netifd: radio0 (2362): Device setup failed: HOSTAPD_START_FAILED

hapac3

anything i can do to get this working?