Meshing with multiple Mesh-Portals

Hello at all,

I've got some WNDAP360 AccessPoint here with OpenWrt SNAPSHOT r6350-175b262328 Firmware on it.
I want to do a Mesh Network with them.
I already got to configure the Mesh Interface and all AccessPoint are connecting to each other.
This is my actual network connection. Everything is working fine. No error Messages at all.

What I need and want to do is the following thing:

When I now conenct the secund AccessPoint I got a lot of messages like:

kern.warn kernel: [ 3829.727147] br-LAN: received packet on wlan0 with own address as source address

What do I need to do that I can do a "Full Mesh"?
I already tried to activate STP.. Without any changes...

Config of AP1:

root@04-A1-51-92-E9-C1:/# cat /etc/config/network

config interface 'LAN'
        option proto 'static'
        option ipaddr '172.21.0.63'
        option netmask '255.255.255.0'
        option type 'bridge'
        option _orig_ifname 'eth0.110'
        option _orig_bridge 'true'
        option ifname 'eth0.110'

config interface 'loopback'
        option ipaddr '127.0.0.1'
        option ifname 'lo'
        option netmask '255.0.0.0'
        option proto 'static'

root@04-A1-51-92-E9-C1:/# cat /etc/config/wireless

config wifi-device 'radio0'
        option channel '11'
        option country 'DE'
        option disabled '0'
        option htmode 'HT20'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:11.0'
        option type 'mac80211'
        option legacy_rates '1'

config wifi-iface
        option device 'radio0'
        option mode 'mesh'
        option mesh_id 'mesh.guenthart.intern'
        option mesh_fwding '1'
        option encryption 'none'
        option network 'LAN'

Config of AP2:

root@04-A1-51-92-E8-61:/# cat /etc/config/network

config interface 'LAN'
        option proto 'static'
        option ipaddr '172.21.0.64'
        option netmask '255.255.255.0'
        option type 'bridge'
        option _orig_ifname 'eth0.110'
        option _orig_bridge 'true'
        option ifname 'eth0.110'

config interface 'loopback'
        option ipaddr '127.0.0.1'
        option ifname 'lo'
        option netmask '255.0.0.0'
        option proto 'static'

root@04-A1-51-92-E8-61:/# cat /etc/config/wireless

config wifi-device 'radio0'
        option channel '11'
        option country 'DE'
        option disabled '0'
        option htmode 'HT20'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:11.0'
        option type 'mac80211'
        option legacy_rates '1'

config wifi-iface
        option device 'radio0'
        option encryption 'none'
        option mode 'mesh'
        option mesh_fwding '1'
        option mesh_id 'mesh.guenthart.intern'
        option network 'LAN'

Config of AP3:

root@04-A1-51-92-E9-E1:/# cat /etc/config/network

config interface 'VLAN110'
        option proto 'static'
        option ipaddr '172.21.0.65'
        option netmask '255.255.255.0'
        option type 'bridge'
        option _orig_ifname 'eth0.110'
        option _orig_bridge 'true'
        option ifname 'eth0.110'

config interface 'loopback'
        option ipaddr '127.0.0.1'
        option ifname 'lo'
        option netmask '255.0.0.0'
        option proto 'static'

root@04-A1-51-92-E9-E1:/# cat /etc/config/wireless

config wifi-device 'radio0'
        option channel '11'
        option disabled '0'
        option htmode 'HT20'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:11.0'
        option type 'mac80211'
        option country 'DE'
        option legacy_rates '1'

config wifi-iface
        option device 'radio0'
        option encryption 'none'
        option mode 'mesh'
        option mesh_id 'mesh.guenthart.intern'
        option mesh_fwding '1'
        option network 'VLAN110'

I don't know if it's important:
The APs are connected to a configurable Switch (Enterasys C3G124-24P).

Thanks for helping

Greetings
superwinni2

You've definitely got a network loop there. I'm surprised that STP isn't shutting down one of the bridges. You have it activated on all of the bridges in all of the APs, as well as the switch, yes?

STP (now RSTP) wasn't really designed to enable redundancy, but more to prevent catastrophic failures when network loops were inadvertently introduced. If you can't get the stability you want with STP, you might have to look at routed links from the APs and an appropriate dynamic routing protocol.

Hi jeff,

thanks for answering.
Yes I've got a network loop :smiley:
I tried everything with STP but nothing helps....

With dynamic routing protocol you man something like B.A.T.M.A.N or OLSR?

Greetings

Hmmm, strange. I've had a similar topology when configuring stations here without issue. You might want to check that STP is working properly with the physical switch's diagnostics or SNMP traps.

The 802.11s mesh should take care of itself, so you don't really have a very dynamic topology. I was using "dynamic" to mean "not static". As my networks are able to resolve things with STP, I haven't gone the next level. For me, that would be something like BIRD on the mesh-to-wired gateways and your choice of OSPF, RIP, whatever. With a network of relatively simple topology and very little delay, unless one goes haywire, the exact routing algorithm is probably unimportant.

There are probably ways of doing it with everything from shell scripts on up, but I'm guessing that purpose-designed software that is widely deployed is going to be more reliable and trouble-free, especially in the long run.

I haven't tried this, but https://mjuenema.github.io/80211s_wireless_mesh/ shows a similar topology and states

Bridging the wireless mesh and the LAN

The alternative to routing between a mesh and a non-mesh network is bridging them.

  • Create a bridge with the non-mesh and mesh interface. Disable Spanning Tree on this bridge.
  • Configure the Mesh Gateways to send HWMP gate announcements.

https://github.com/o11s/open80211s/wiki/HOWTO describes gate announcements, presently near the bottom of the page.

1 Like

Have you figured out how to set it up? I've played with mesh_hwmp_rootmode and mesh_gate_announcements but still have a network loop.