Meshing on both bands

hey,
i have 3 router, 2 of them are 2,4 and 5ghz capable, one is only 2,4ghz.

so my idea was to add a mesh point to every band on both 2,4 and 5ghz capable router.

but as soon i add a meshpoint to both 2,4 and 5ghz the first two router connect to both bands parallel and my network becomes almost unreachable because of that.

is there a way to solve this problem? if i understand right, this shouldn't be even a problem.

Are you perhaps bridging both bands on each device, and thus creating network loops?

1 Like

i have set option network 'lan' on both, so maybe yes. is there a way around this?

config wifi-iface
        option device 'radio1'
        option mode 'mesh'
        option mesh_id 'OpenWrt_5ghz'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option network 'lan'
        option encryption 'sae'
        option key 'secret'

config wifi-iface
        option device 'radio0'
        option mode 'mesh'
        option mesh_id 'OpenWrt'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option network 'lan'
        option encryption 'sae'
        option key 'secret'

i did this on both devices.

STP should help this. Enable STP on the lan networks.

2 Likes

You'll likely need a routing protocol other than 802.11s as provided by mac80211s as, last I knew, it didn't manage cross-device meshes.

stp seems to be the solution, thank you :slight_smile:

one last question: how the router handles the connection if both 2,4 anf 5ghz mesh is aviable? does it use the strongest or does it even mix? can i somehow force 5ghz in this case?

No, the "spanning tree protocol" just cares about "distance" between nodes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.