Mesh nodes not connecting after setup

Hey,

I'm trying to set up a mesh network between two nodes, but the nodes aren't connecting.

I currently have a wireless AP (Linksys MX4200v1) connected to a switch (Netgear GS324T), which in turn is connected to my router (OPNsense). The AP is broadcasting two SSIDs on 2.4 GHz, with each of these SSIDs bridging to a respective VLAN.

As the walls here are fairly thick, I don't always get good reception with all my devices, so I'm looking to extend both network(s) via B.A.T.M.A.N. mesh to the living room (hence the mesh network will only consist of two nodes / one node and one gateway). I might want/need to add other VLANs to the mesh later on, but the number of nodes is unlikely to change in the foreseeable future.

So I followed this tutorial to set up a mesh point on my Linksys AP. I subsequently dug up my GL.iNet GL-B1300, reset it to factory aka OpenWRT defaults, gave it a static IP next to the Linksys (192.168.1.3 and 192.168.1.4, respectively), and added a mesh point on it with the same configuration as on the Linksys. However, when I SSH into either of them and run iw dev $MESH_IFACE station dump as per the tutorial (replacing $MESH_IFACE with the interface name), I only ever get a single station. What am I missing?

Here's my configuration:

Linksys MX4200v1 (aspiring mesh gateway)

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT20'
	option cell_density '0'

config wifi-iface 'mesh'
	option device 'radio0'
	option mode 'mesh'
	option ifname 'mesh0'
	option network 'lan'
	option mesh_id '8579'
	option encryption 'sae'
	option key ‘REDACTED’
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel '10'
	option band '2g'
	option htmode 'HE40'
	option cell_density '0'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+2'
	option channel '100'
	option band '5g'
	option htmode 'HE80'
	option disabled '1'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Personal'
	option encryption 'sae'
	option key 'REDACTED'
	option network 'personal_vlan'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid ‘Guest’
	option encryption 'sae'
	option key 'REDACTED'
	option network ‘guest_vlan’

(I used the template provided here and adjusted the mesh_id and key.)

GL.iNet GL-B1300 (aspiring mesh node)

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT20'
	option cell_density '0'

config wifi-iface 'mesh'
	option device 'radio1'
	option mode 'mesh'
	option ifname 'mesh0'
	option network 'lan'
	option mesh_id '8579'
	option encryption 'sae'
	option key ‘REDACTED’
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'testnet'
	option encryption 'sae'
	option key ‘REDACTED’
	option network 'lan'

If you've got a mesh of two nodes, each will only have a single peer.

Oh, I hadn't thought of that. I would've guessed it shows you all stations, not just the associated ones. Thanks for clarifying!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.