Mesh between WRT1900ACS and FritzBox 7412

Hi,

I try to get a working mesh between a Linksys WRT1900ACS and a AVM Fritz!Box 7412. On both devices I've installed OpenWrt 19.07.0-rc2.

I've installed wpad and have the following config on both devices:

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option wpa_disable_eapol_key_retries '1'
        option key 'gfhfghf'
        option ssid 'wifi-ap'
        option encryption 'psk-mixed'

config wifi-iface 'wifinet1'
        option network 'lan'
        option device 'radio0'
        option mode 'mesh'
        option mesh_id 'wifi-mesh'
        option key 'gfhfghfghf8'
        option encryption 'psk2/aes'

But Luci still shows "Wireless is not associated". On the FritzBox I've found the following logs after enabling the mesh device:

Thu Dec 26 22:55:52 2019 daemon.notice hostapd: wlan0-1: AP-ENABLED
Thu Dec 26 22:55:52 2019 kern.info kernel: [ 3073.328917] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Thu Dec 26 22:55:52 2019 daemon.notice wpa_supplicant[9009]: Successfully initialized wpa_supplicant
Thu Dec 26 22:55:52 2019 daemon.err wpa_supplicant[9009]: Line 6: invalid key_mgmt 'SAE'
Thu Dec 26 22:55:52 2019 daemon.err wpa_supplicant[9009]: Line 6: no key_mgmt values configured.
Thu Dec 26 22:55:52 2019 daemon.err wpa_supplicant[9009]: Line 6: failed to parse key_mgmt 'SAE'.
Thu Dec 26 22:55:52 2019 daemon.err wpa_supplicant[9009]: Line 7: too large mode (value=5 max_value=4)
Thu Dec 26 22:55:52 2019 daemon.err wpa_supplicant[9009]: Line 7: failed to parse mode '5'.
Thu Dec 26 22:55:52 2019 daemon.err wpa_supplicant[9009]: Line 14: failed to parse network block.
Thu Dec 26 22:55:52 2019 daemon.err wpa_supplicant[9009]: Failed to read or parse configuration '/var/run/wpa_supplicant-wlan0.conf'.
Thu Dec 26 22:55:52 2019 daemon.notice netifd: radio0 (8800): cat: can't open '/var/run/wpa_supplicant-wlan0.pid': No such file or directory
Thu Dec 26 22:55:52 2019 daemon.notice netifd: radio0 (8800): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process  path (/proc/exe)
Thu Dec 26 22:55:52 2019 daemon.notice netifd: radio0 (8800): Command failed: Invalid argument
Thu Dec 26 22:55:52 2019 daemon.notice netifd: radio0 (8800): Interface 1 setup failed: WPA_SUPPLICANT_FAILED
Thu Dec 26 22:55:52 2019 daemon.notice netifd: Network device 'wlan0-1' link is up

Cheers,
wrter

I wasn't aware that a mesh could be an encrypted AP. I thought it had to be an unencrypted Ad-Hoc network.

It should be possible. Here is a manual:
https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s

On the FritzBox I get this message away using wpad-mesh-openssl

From manual:

Screenshot from 2019-12-26 18-03-08

So again, are you sure - what mesh technology are you using?

I'm not an expert in this stuff, but I try to use 802.11s

Some logs from Linksys with mesh device enabled:

Fri Dec 27 00:18:43 2019 kern.info kernel: [ 1598.424485] IPv6: ADDRCONF(NETDEV_UP): wlan1-2: link is not ready
Fri Dec 27 00:18:43 2019 kern.info kernel: [ 1598.424504] br-WWAN: port 2(wlan1-2) entered blocking state
Fri Dec 27 00:18:43 2019 kern.info kernel: [ 1598.424509] br-WWAN: port 2(wlan1-2) entered forwarding state
Fri Dec 27 00:18:44 2019 kern.info kernel: [ 1598.539006] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-2: link becomes ready
Fri Dec 27 00:18:44 2019 daemon.notice hostapd: wlan1-1: interface state COUNTRY_UPDATE->ENABLED
Fri Dec 27 00:18:44 2019 daemon.notice hostapd: wlan1-1: AP-ENABLED
Fri Dec 27 00:18:44 2019 daemon.notice netifd: radio1 (7649): ip: SIOCSIFFLAGS: Operation not permitted
Fri Dec 27 00:18:44 2019 daemon.notice netifd: radio1 (7649): Interface 2 setup failed: IFUP_ERROR
Fri Dec 27 00:18:44 2019 daemon.notice netifd: Network device 'wlan1-1' link is up
Fri Dec 27 00:18:44 2019 daemon.notice netifd: Network device 'wlan1-2' link is up

Marvell wireless? If so, last I checked neither 802.11s nor ad-hoc is supported.

2 Likes

Yes. Seems you are right :frowning:

My WRT1900ACS seems to support Mesh.

root@OpenWrt-AP1:~# iw list | grep "Supported interface modes" -A 9
        Supported interface modes:
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 1:
                Capabilities: 0x106f
                        RX LDPC
                        HT20/HT40
--
        Supported interface modes:
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 2:
                Capabilities: 0x106f
                        RX LDPC
                        HT20/HT40
root@OpenWrt-AP1:~#

However, like you I also have the Wireless is not associated

Without encryption it doesn't work too.