Mesh and stp problem

Hi All:
I use 3 AP to form a mesh netowork. 2 AP act as MPP, 1 AP act as MAP. 2 AP connect to the same network which can access to the internet . However when 2 MPP mesh link is up, the bridge br-lan warn "received packet on eth0 with own address as source address". It may be a net loop. I try to enable stp on br-lan. But it seem to not work. MPP see the internet is on its wireless side not lan side. Would anyone kindly help me fix this problem.Thanks. My config fie of MPP as flowing:
cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        option country 'US'
        option channel '36'
        option txpower '19'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'lede'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'lede'
        option encryption 'none'
        option disabled '1'

config wifi-iface
        option device 'radio0'
        option mode 'mesh'
        option mesh_id 'test'
        option encryption 'none'
        option network 'lan'

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc8:ae08:4013::/48'

I also change default bridge id to 32769. My internet bridge id 32768.

config interface 'lan'
        option type 'bridge'
        option _orig_ifname 'wlan0-1 wlan0 radio1.network1'
        option _orig_bridge 'true'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option stp '1'
        option ipaddr '192.168.33.111'

iw dev wlan0 station dump

Station xx:xx:xx:00:00:03 (on wlan0)
        inactive time:  1450 ms
        rx bytes:       239
        rx packets:     3
        tx bytes:       369
        tx packets:     4
        tx retries:     29
        tx failed:      2
        signal:         -90 [-96, -92] dBm
        signal avg:     -89 [-94, -91] dBm
        tx bitrate:     13.0 MBit/s MCS 1
        rx bitrate:     6.0 MBit/s
        mesh llid:      26402
        mesh plid:      1906
        mesh plink:     ESTAB
        mesh local PS mode:     ACTIVE
        mesh peer PS mode:      UNKNOWN
        mesh non-peer PS mode:  ACTIVE
        authorized:     yes
        authenticated:  yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        connected time: 2 seconds