Meraki mx60 Uart console cable connection

Remember you have to switch RX and TX connection to get correct output with serial console connection from your USB serial to your Router


Connect on Console (J2). P1 is closest to the H1 screw, and P4 is closest to the JTAG port.

P2: RX
P3: TX

Serial connection parameters:

115200 / 8N1


@fotosanook, welcome to the community!

I did. I got a lot of fffffff 2 ffffff. I got better result on ms220 8p device. Some reason mx60 is not working. Please advise.

What Serial USB device you using ?

It is working on ms220 8p surely. how to connect on mx60 is there a trick. I am getting only ffffff and stopped.

  • Change software or hardware flow control.
  • Only connect: TX, RX and GND.


I have the same issue: I have a PL2303 serial-to-USB functional adapter (tested with other equipment with serial console) and regardless of the terminal software I use (screen, minicom, miniterm running on Ubuntu Linux) what I get is just strange characters:


I have tested {115200, 8N1} configuration and all the other lower serial speeds down to 9600, with the same result (for some speeds I did not get any characters on the console). I have tested with software flow control off (default) and on, without any change.

I am running out of ideas, so any comment will help.

Thank you in advance!

So, did you change hardware flow control as noted above?

I do not have any pins (RTS/CTS) connected for flow control; only Tx/Rx/GND are connected. Just for the sake of completion I did this test and nothing happened, just the terminal software hanged up with errors showing on dmesg:

[12370.566915] pl2303 ttyUSB0: error sending break = -32
[12395.398230] pl2303 ttyUSB0: pl2303_get_line_request - failed: -32
[12395.398496] pl2303 ttyUSB0: pl2303_get_line_request - failed: -32

One comment about the hardware connection: connecting the Tx/Rx pins to the MX60 board works only in what it seems to be the "wrong" config: DB9/pin2(Rx) -- to --MX60/pin2(Rx) and DB9/pin3(Tx) -- to --MX60/pin3(Tx). The cross connection (theoretically correct) does not produce any result on the console.

Not needed.

  • Where is this log coming from?
  • What terminal software are you using?

I use minicom on Ubuntu machine, with {115200, 8N1} - I've only altered the flow control to access the Meraki. I can test this for you in a few hours.

There seems to be an issue with your device (and a possible workaround), see:

I will look for another Serial-2-USB adapter and see if the result is different.

I'll get back with details. Thank you for your time!

i tried everything too.

OK, I have tested with a different pl2303 Serial-2-USB adapter, again, verified as being functional with another device with serial console. The result was almost the same: just strange characters, but without the pl2303_get_line_request error in the logs (easy visible via dmesg). I have tested with multiple terminal software applications:

  1. minicom (minicom -o -D /dev/ttyUSB0 -b 115200) both with hardware flow-control enabled in configuration (no output at all in the console) and without hardware flow-control (gibberish text).
  2. screen (screen /dev/ttyUSB0 115200) with the same garbage result on the console
  3. miniterm, Python based terminal, (miniterm /dev/ttyUSB0 115200), again with strange characters displayed.

I am really out of any options :frowning:

Any suggestions?

i will get the log from what I got yesterday and paste it here in the evening. I think there is like a keystroke that needs to do the break CRTL+[ for example to get into the mode. After those ffffff 2 fffffff, it just stopped.


I am able to access my Meraki with these settings. Hope this helps.

mx60 right. I got the output below. Still no luck

got a buspirate? :wink:

doesn't work with me. My cable is functional.

as a last resort check if the solder joints on the boards are good, re apply heat and solder

post a picture of the board if you can so we can compare if maybe also board has undergone revision changes

maybe a u-boot version changed?

my board is white, in the web is green. I need to take a picture and update

1 Like