Meraki MR52 5g radio problem


I have flashed both an MR42 and an MR52. I have configured them identically other than interface IPs and hostnames. They are configured as dumb APs with vlans. I can connect to all SSIDs on the MR42, on both the 5g and 2.4g radios.

However, with the MR52, I cannot connect via the 5g radio. It's visible to the client device (pixel5 phone), but does not connect and nothing is logged by hostapd when I do attempt to connect.
One unexpected difference I found between the MR42 and MR52 is that radio0/1/2 are assigned differently. With the MR42, the acbgn single channel radio is radio0 whereas on the MR52 it's radio2.
I tried 22.03.3 and 22.03.5. I'm wondering if this is a hardware fail as I did not use the device myself prior to flashing it. Anyone else having issues or suggestions re the 5g radio on the MR52?
Just to add the MR52 is powered by PoE and does seem to get pretty warm!

I tried 23.05.0-rc2 and 5g appears to be working. I haven't compared thruput with the MR42.
I'm interested what changes occurred between 22.03 and 23.05 that might affect MR52 5g, but not sure where/how to look (ath10k-board-qca9984?).

EDIT: Having got a successful connection once, I seem to be back where I was. Something I notice with the newer firmware, the available power levels vary with maximum available variously 100, 130, and 397mW. I'm wondering if this is a hardware problem?

I just tried a 12V DC adapter rather than PoE. The MR52 now functions as expected with no spurious tx power values displayed in the SSID config dropdown. It also seems to be running cooler. So I can only think there's a fault with the PoE injector (TP link TL-PoE160S 802.3at), the PoE port on the Meraki or a bad cable. So marking as solved.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.