Meraki MR42 sysupgrade failed?

Hi everyone,

Recently, i sucessfully install OpenWRT on 2 Meraki MR42 devices, using UART method.
At the end of install, it shows version :
OpenWrt SNAPSHOT r23456-81f667513a / LuCI Master git-23.158.78004-23a246e

Before starting configuration, i wanted to install lastest supported version. So i download the following file on MR42 page, and send it via the Luci "system - Flash new firmware image" menu. I uncheck the "keep settings", as nothing was set.

Now i can't access my device anymore. Did a do something wrong ? Is it possible to recover it without opening again ?

Thanks for your help !

If there's a documented recovery procedure, you should try that - and flash a factory image. Images contain no migration mechanisms for downgrades, only for upgrades. Wiping settings was the smart thing to do but it won't catch any changes that were done to the images themselves.

Thanks for your reply ! I tried the following without success:

Download the "kernel" image from :

Then mount a tftp server on my computer, and press reset on the Meraki. I saw the file uploading, rooter booting (whiote led flash, then fixed). But still no ping on nor dhcp request.

I'll open it this night and look at the serial monitor.

I've a second unit up and running, and i'm a little scared about updating. Can someone give me advices on how to do it safely ?

It seems the serial pins are there (at least going by an image floating around on the forums here, so better hook up serial to see what's going wrong exactly at boot.

So... after looking at the serial monitor, everything is OK. The only thing is br-lan config is reset to 'static' ip. Normal, i wipe settings.

I had however tried to contact him with an ip on the same range.

So now i've to understand the versions of OpenWRT !

The first install i made shows:
OpenWrt SNAPSHOT r23456-81f667513a

For me it doesn't look a "stable version", so i install :
OpenWrt 22.03.5, r20134-5f15225c1e

Can you explain to me (or link me an article) about versions names ? I guess the higher the "r*****", the newer the version?

Yes. The hash after the dash is the last git commit your image was built from. The revision number (r.....) is a number that counts the amount of commits since the start, and cannot be readily linked to the tree. The commit hash however, you can retrieve that through or the GitHub mirror.

BTW I've had instances where not setting the right subnet on the client - ie setting e.g. but not specifying it's a /24 - would prevent me from connecting. Did you double check that?

To be sure (and because my device is still opened !) i tried to flash it again. This time no problem to connect to .

So it must have been a user problem rather than a software problem !

Thanks a lot for replying, and for your explanation about versioning.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.