Meraki MR33 serial connection issue

Hi, I am trying to connect an USB-Serial cable (SWEEX CD005 with Prolific PL2303 chip inside) to the internal GND, RX and TX pins. Vcc is unconnected. But whatever I do, I get garbage on the serial console. I tried from PUTTY under Windows and from miniterm under Linux, same result. I tried all possible serial parameters (115200-N-8-1 and most others), same result. I even soldered 3.3V voltage limiting zener diodes between GND and the serial lines, but it did not help.
What else do you recommend?


  • I'd try flipping flow controls.
  • Ensure TX-to-RX and RX-to-TX


Remove these.

I did a quick search for SWEEX CD005. This does not look like a 3.3V serial adapter, as these often do not have a DB9/DB25 connector. could not find any specs for this thing the quick way. did you have a look at the TX output voltage of the SWEEX CD005 using an oscilloscope? I used a CP2102 based adapter which worked fine with the MR33. also check that the MR33 pins make contact, as they are quite short, as far as I remember.

1 Like

I will check the signal with a scope tomorrow. Anyway, I read there are many counterfeit USB-Serial cables claiming Prolific chip inside. So I tried with a Trendnet TU-S9 and also with a Delock #61856 adapter (both passed the Prolific genuinity test) with the same result.
Next step will be to use an Arduino micro for the USB-Serial task. I will report on the result.

I connected the TX-RX-GND pins from an Arduino micro to the MR33 pins, using the following sketch:

void setup()
{ Serial.begin(115200);
  Serial1.begin(115200); }
void loop()
 { if (Serial.available())
  { Serial1.write(; }
  if (Serial1.available())
  { Serial.write(; }}

It works perfectly with the MR33.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.