Meraki MR30H OpenWrt Install


Hoping someone can help me out. I have an unused Meraki MR30H. I've tried to install OpenWrt using the MR33 image/guide. I can serial onto the device, get U-Boot running and the initial .itb image on there. But once that initial non-perminant image is on, I can't reach it on the default Tried mulitple things like changing the IP from the serial console and playing around with the interface settins, but its like it wont pass traffic for somereason.

I can see the eth0 interface coming up via the serial connection. Its using a bridge br-lan, and I am able to reach it on the IP address when its in the U-Boot stage.

Am I missing something, or is it because I am trying to use the MR30H with the MR33 image that isn't happy?

Apologies in advanced, I'm not a big linux user. Just fancied this as little project.


Are you saying that you used the instructions and files for a supported device - to flash an unsupported one?

Device search:[Model*~]=MR30H

If so, that's likely the problem.

Maybe because it's the wrong device?

That would be my guess. Why are you under the impression that an image for another device will work with yours?

U-Boot != running_OpenWrt

(It seems like you're merely saying the boot loader works - yes it should.)

Hi lleachi,

I was mainly following this guide

It mentions it can be done on other models as well. Being a MR30, was hopeful that its part of a MR3x line and so the MR33 image may work.

I can also get it into OpenWrt, but its the non-perminate stage (sorry don't know the terms), but only usable via serial. If following the guide, the part after the first TFTP upload of the itb image. I see the OpenWrt banner and such, if that makes any sense.

This isn't a link to an official OpenWrt Wiki. From the link I posted above - the MR30H doesn't seem supported.

It says you can do this on other devices with serial doesn't say they have the available firmware. In any case, You may with to ask the owner of the website, since installing firmware on an unsupported devices isn't a supported OpenWrt procedure.

Additionally, following instructions to blindly flash memory addresses for other devices could brick your device or WiFi chips. It's a good thing you didn't destroy U-Boot.

Can you describe it, then?

OK, that makes sense - I understood that already.

Yes it makes 100% sense, are you making an additional inquiry?

It seems like you're tying to rig a firmware to work with another model. This isn't a supported install method here, so I'm not sure you'll get much more information.

But, feel free to wait for more people to respond - or make a thread in the "For Developers" section to determine interest in supporting this device (glad you have serial access to assist).


Unsupported as you say, I'll just leave it. Was worth a go. But thank you for clarifying.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.