Meraki MR18 Firmware 19.07.8 Not Working

I upgraded the MR18 Firmware to 19.07.8 and it is not working.

I had it setup as as Access Point and had fixed its IP address and turned off the DHCP Server. I have tried to do the same but cannot get the login screen to configure the Wifi radios.

It all worked on the previous firmware. I can't remember the version, but was 19.x.x.

Can I revert back to the old firmware? Where can I download old compatible firmwares for MR18?

Any ideas?

Thanks,

Same place as for the non working ones, just replace the version no in the url.

Thank you frolic. Do you know which versions the previous ones are?

19.07.0 .1 .2 ... .7

For MR18: 17.01.0 up to 19.07.8

See https://downloads.openwrt.org/ for all available OpenWrt releases.

Tmomas,
Thanks for the reply. The old versions are 17.x.x.

I have now managed to locate and find the firmwares.

The issue I now have is even for the older firmwares…

A. I have installed them and logged in to the Lede screen and switched off the DHCP server and

B, Configured a static IP address,

I cannot get the Lede login prompt after connecting the AP to to the main Sky router via Ethernet.

So what I did is I reset it again and this time also configured the wireless SSIDs and enables two radios. I am able to see the WiFi SSIDs and connect to them. But can’t login to the Meraki through the lede login prompt.

Checking the connected devices on the Sky router, I cannot see it listed there. Why would this be?

Thanks,
ASenna04