Meraki MR16 bad checksum

Hello guys,

I am trying to install openwrt on my meraki mr16 however no matter which build I choose to load the image into RAM I get bad checksum readings from the Meraki:

ar7100> tftpboot 0x81000000 openwrt-ar71xx-generic-mr16-initramfs-uImage.bin; bootm
Trying eth0
pll reg 0x18050010: 0x110000 Using eth0 device
TFTP from server 192.168.1.101; our IP address is 192.168.1.2
Filename 'openwrt-ar71xx-generic-mr16-initramfs-uImage.bin'.
Load address: 0x81000000
Loading: checksum bad
checksum bad
checksum bad
#########################checksum bad

Abort

Booting image at 81000000 ...

Image Name: MIPS OpenWrt Linux-3.18.11
Created: 2015-04-12 17:13:17 UTC
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 3225890 Bytes = 3.1 MB
Load Address: 80060000
Entry Point: 80060000
Verifying Checksum ... Bad Data CRC

Anyone else experienced this issue?

So i tried almost every bin file from here: https://github.com/riptidewave93/Openwrt-MR12-MR16/releases and I gave up on release 1.2

If someone is willing to help I could spit out more info :slight_smile:

Thanks,
Vlatko

bump, anyone?

@vlatkojordanov90, welcome to the community!

Can't bump if you're the only poster in a thread. Didn't work.

Hey man,

Thanks for reaching out and thanks for the welcome! :slight_smile:

I thought bumping my thread as it got ignored but hey we learn something new every day :slight_smile:

I just checked https://openwrt.org/toh/meraki/mr18#installation but it doesn't feel as the same procedure for MR16 or maybe I am doing something wrong?

Would you mind helping out how to navigate downloads.openwrt.org so I can choose the correct bin file please?

Device is MR16
Board version is 1.00
CPU is AR7161-BC1A http://nice.kaze.com/AR7161.pdf

Thanks,
Vlatko

OMG, correction!!!

https://openwrt.org/toh/meraki/mr16#installation

You should also learn that it's at minimum - unnecessary too. All the posts show up in order; and they can be seen and sorted - including by 0 replies.

https://downloads.openwrt.org/releases/19.07.2/targets/ar71xx/generic/

The files are in this directory.

Apologies for the confusion, my ToH search auto-completed to "mr18".

Hi Man,

I've already tried that guide before I even wrote my post here, and that's the output I got when I tried uploading the boot image into ram.... Haven't dared to directly upload the flash image as this one is failing.. It might work but at the same time the chances of bricking the device are much higher!

So if anyone has a stable release of that boot image would be much appreciated if he can share it so I can give it another try,

Cheers,
Vlatko