Meraki MR 33 - TTL Serial TXD problem

Hi all,

This issue seems to come up a bit in the forums, its really frustrating me, I am trying to flash a Meraki MR 33, issue is, I cannot seem to transmit anything through the serial connection. I have the CH340 chip (win10 recognised it and installed drivers, I also ended up downloading the latest drivers and tried that too). Connecting to the headers I get readable output everytime, once boot is finished if I hit enter nothing happens (I believe I should get a carriage return) if I run "" it sits at "uploading image" forever. I have also tried it on a linux vm, I get the exact same results.

I did a loopback test on the serial, it does work. I have checked flowcontrol, parity, stop bits etc a million times. I have tried it with and without the 3.3vcc connection (I believe this is not required, just RXD, TXD and GND) . This TTL adaptor literally took 2 months to arrive from China so I really want to get it to work! The Meraki is brand new, I took it out of the box for this flash, so I would think very unlikely the RXD header is faulty. is there any other test I can do to rule out if its the meraki or the serial adaptor?


I do not understand exactly what you want to say, you mean the TX pin does not work ? Can't you send what you type to the Meraki board ?
In my experience, the problem with TX is because the adapter voltage level has not been set at 3.3v.

Most of the serial adapters can work with two voltages level of 5v & 3.3v but the router board only works with the voltage level of 3.3v. These adapters often have switch/jumper to change operating voltage level.

1 Like

Hi Leeandy,

What I mean is, with my terminal window open I can see the output during bootup, but when I press the enter key or try and type something nothing comes up. The voltage is definitely 3.3v, I measured using a voltmeter. However if I connect the TXD pin to the RXD pin on the serial adaptor I can echo out what I am typing in the terminal window which would indicate that the adaptor is working ok.

Can upload your adapter image ?
Let recheck the soldering joint at the rx pin on router board to make sure it has good contact.

When you have not set the correct voltage level for the adapter, it can still display outputs from the router board, but will not send what you types to the router, that is my experience.


This is the adaptor I have, (ignore the pictured jumper position) with no jumper, the TXD/RXD operate at 3.3v, with a jumper across 5v and VCC they operate at 5v and the jumper across VCC and 3v3 they operate at 3.3v. So I have tried with and without the jumper (but never at 5v).

I am thinking of trying to connect a wire form the TXD pin to the chip to see if it helps. However as loopback test is working I suspect that connection should be ok.

I have another meraki, I will also give that one a try, I am sure its bootloader will be too new to use openwrt but will be a good test to see if the serial connection works.

You need set jumper on VCC & 3v3.
Remember never connect 3v3 pin between router & adapter.
Good luck.

That's exactly what I said I had already done :slight_smile: