medion md 86979 no firmware

Hello

i tried to install on openwrt on md 86979 but something went wrong preventing me from getting on md 86979.

it looks like there is no firmware left.

i tried to connect via TTL serial port but i can't.

can someone give me a simple explanation how to get a firmware on my medion md 86979? (if there are possibilities)

It doesn't seem to be supported.

i tried this
https://openwrt.org/toh/medion/md86587
but after step 7 is (reboot) the nas does nothing anymore

someone happens to have a firmware from the NAS that I can put on it via TTL

Your device is not even in the compatible list.

is right .. i tried. unfortunately went wrong :face_with_raised_eyebrow:

I suggest you try to restore the OEM firmware using the serial console somehow.

that is a problem. I can't find an OEM firmware anywhere

I suggest you contact the vendor then.

what software do you use to send a file via ttl

Hyperterminal, SecureCRT, maybe Putty.

dont work but thanks

The MD86979 seems to be compatible. So this software should be able to restore the firmware using a prepared disk.

how do I get it on my nas?

Download the files to a Linux system. Connect a harddisk (which will be wiped) to that system, and run as root

 ./build.sh <device> <MAC-Address>

MAC-Address is the desired mac address, device is the devicenode of that harddisk. (Doublecheck, it will be erased). Put the disk in the NAS and power it up. It should boot from that disk, and the booted system wil write flash partition dumps to flash. When it's ready (don't know how you would see that, but it can't take more than 10 minutes), switch off the NAS and remove the disk. It should be able to boot from flash. The disk must be removed, as it takes boot precedence over flash.

I don't have a linux system :frowning:

the HDD is empty, cannot find the mac address.

can't flash with ttl?

Then use a Linux Live system, or a NAS.

You can use any mac address. It's not a check, it's just the mac address the box will have.

If nothing is alive at the other side, then no. If you can get in the bootloader, maybe. Depends on the capabilities of the bootloader. In any case it won't be nice. The firmware partitions are >100MB, which will take hours to upload over serial.

I can't download everything.
mtd2.data
mtd3.data

the other does

I managed to download. :slight_smile:

how do I put the files on it in linux?
do I need to format the HDD, and then just copy the files?

No, you have to run the build.sh script. It will write the files to the raw disk. There will be no filesystem.

i have a linux system running.
but the build.sh cannot open

no rights at first, now

cannot access (device) no such file or directory
cannot access (mac address) no such file or directory