MediaTek MT7916 Not Detected

Hello,

I recently bought a MediaTek MT7916 for use in a wireless router that I am building. Unfortunately, I'm having issues getting the card detected by OpenWRT. Here's a list of the troubleshooting steps I've taken. Most are hardware-related but I have done some software-related shenanigans based on my level of expertise, all of which have failed:

Hardware:

  • Put the card in another slot on the motherboard
  • Swapped out the MT7916 for another MT7916
  • Swapped out the adapter card for another adapter card

Software:

  • Installed the MT-7916 firmware
  • Reinstalled OpenWRT

I don't know if its a hardware-related issue but I feel I'd have to get VERY unlucky to get two dead cards in a row.

what hw platform ?

what does lspci say ?

1 Like

HW platform is x86-64

I sshed into the router (firrst time I've ever sshed into something I might add) and installed the programs that allow you to do lspci. I don't see the wifi card on the list, however. It's plugged in though.

thank god you didn't provide any details, I mean, there's only one x86-64 product out there, right ?

Also MT7916 is very new so your version of OpenWrt is also important.

from what I can gather it is supported inside the snapshots and maybe in the new release candidate.

see here for reference:

edit

Also I readed you may need kmod-mt7915e drivers.

Thank God you never asked for the system specs. Custom job.

CPU: Ryzen 5 2400G
RAM: 32GB DDR4 3000
Motherboard Asrock B450M pro/4-CB
Onboard NIC: Realtek RTL8111H
Add-in Card 1: IBM 00E0838/Intel PRO/1000 PT Quad Port Server Adapter (Intel 82571EB) based
Add-in Card 2: NICGIGA 10Gbe card with Marvell AQtion AQC113C Controller
Add In Card 3: MediaTek MT7916 Mini PCI Card on adapter board

Those are installed. Believe it's a dependency for the MT7916.

Funnily enough I have it working on a very similar platform on my router at home without issue. Popped it in and installed the drivers and it was immediately detected.

Are you sure you have enough current on the 3.3V rail provided for MT7916E to work properly? I remember it being quite power hungry esp. during start up...

It's possible but I have used the same adapter card for my other setup without issue. Now it could be I got lucky and got one that allowed it but the adapter card is pretty simple.

Same motherboard as well? Because that's what go to supply the card with sufficient current...

Hmmmm... I don't know if that is going to be a factor. It's a different motherboard than what I'm using at home but a PCI Express slot can, if built to proper spec, provide up to 9.9W of power alone to a 1x card, (3.3V at 3A). This exceeds the 9W that the card can theoretically draw. That said, definitely possible.

True, however, a regular PCIe x2 slot provides up to 4 pins with +3.3V (and 9? ground pins on a quick count). If the adapter, in the assumption that mPCIe typically needs only about max. 1A doesn't connect all of them, it depends on how the pins are connected on the board, conductivity of the connector, ...

Well, the power supply should provide 18 amps at 3.3V. If there's a weak link here it could be the motherboard.

Have someone a working setup in OpenWRT for a Mediatek MT7916 wifi card ?

I have purchased this one from AsiaRF https://asiarf.com/product/wi-fi-6e-m-2-ae-key-module-mt7916-aw7916-aed/ and I'm trying to use it as an access point.

I installed OpenWRT master on a virtual machine running in Proxmox and the card it detected inside the VM when using lspci, also I see the firmware and the modules are loaded but I do not see any network interfaces.

root@OpenWrt:~# lspci | grep -i Mediatek
01:00.0 Network controller: MEDIATEK Corp. Device 7906
root@OpenWrt:~# dmesg | grep mt
[    4.595073] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20230202144915a
[    4.607445] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20230202145005
[    4.633205] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20230202143332
root@OpenWrt:~# lsmod | grep mt
cfg80211              315392  5 ath11k,mt7915e,mt76_connac_lib,mt76,mac80211
mac80211              610304  4 ath11k,mt7915e,mt76_connac_lib,mt76
mt76                   61440  2 mt7915e,mt76_connac_lib
mt76_connac_lib        53248  1 mt7915e
mt7915e               122880  0

I tried both with the 5.15 kernel and 6.1 testing kernel and results are the same. Curiously when I use the same card on an Archlinux VM in Proxmox runing on kernel 6.6 it is detected and I'm able to see the two interfaces since it is a DBDC card.

Could it be that the OpenWRT kernel does not have full support yet for this MT7916 chip ?

1 Like

Please boot OpenWrt on the bare iron first (e.g. from a USB stick), to get the virtualization out of the way as a potential complication (at least for a short test).

Hello,

I just tested and booted OpenWRT from an USB stick (directly on bare metal) and the result is the same. The Wifi card is detected I see the modules are loaded but I cannot see any wlan interface being shown.
Also as I mentioned in my previous post on another VM running Archlinux kernel 6.6.2 same hardware the card is detected and I see 2 wifi interfaces.

Are you able to provide any further update on your progress with the AW7916-AED? What was the cause of your issue and what was your solution please?

I've just ordered the AED myself from AsiaRF. Waiting for it to arrive. Not sure when, still saying order processsing but I'd like to be armed and ready to deal with any problems that could present once it gets here. Thank you

Hello,

Until recently I since I could not make it work back then on OpenWRT I did not used it, but in the last week just tried again and I compiled a new OpenWRT x86 image using the 6.6 testing kernel (trunk version) and I deployed it on Proxmox as VM to use it as an access point and PCI passthrough the Mediatek AW7916-AED card to it.

I struggled a lot to make it work since using the default BIOS options I experieced a lot of hangs and VM freeezes. In the end somehow I managed to make it work by modifying a different BIOS options but I'm not entirely sure it is stable so I will need to test it for a couple of days or a week before I can use it in the long run.

If you plan to use it directly on OpenWRT without virtualization (direct install on the hardware) it might work without issues. The setup I'm using is an Aliexpress mini PC with Proxmox installed on it and OPNsense as firewall + OpenWRT as access point both as virtual machines.

The card supports DBDC so you should see two wireless interfaces in OpenWRT/Luci which can be configured as dual band AP 2.4Ghz and 5/6Ghz.

Do you see anything when running: iw list ?

Thanks for the update. Thats really helpful. I will be using it bare metal to test out initially when it arrives but was planning eventually to run it as a container in proxmox, until this morning I ran into a few threads about openwrt unpriviliged containers struggling with PPPoE. Unfortunately Im not a proper hobbyist or developer. Just an ordinary layperson who was searching for (I know its not recommmended) a home all-in-one solution with 6GHz radio and cloud server test bed.

Woudl you mind if I messaged you directly, I dont want to steer this thread off course but i have some other questions regarding your system design