MC7455 QMI no Virtual Interface gets created and no connection

Hy everyone,

First of all this setup worked 2 years ago like charm.

APU2C4 with mSata

The Topic describes the problem really good.

I`m using LuCi to configure it.

uqmi commands output:

uqmi -d /dev/cdc-wdm0 --get-serving-system


    "registration": "registered",
    "plmn_mcc": 232,
    "plmn_mnc": 3,
    "plmn_description": "HoT",
    "roaming": false

uqmi -d /dev/cdc-wdm0 --get-signal-info


	"type": "lte",

	"rssi": -57,

	"rsrq": -9,

	"rsrp": -90,

	"snr": 154


uqmi -d /dev/cdc-wdm0 --get-data-status


uqmi -d /dev/cdc-wdm0 --get-current-settings

"Out of call"

uqmi -d /dev/cdc-wdm0 --wda-get-data-format


As you can see everything looks fine so far.
I did the same things to get it work as 2 years ago.

the virtual interface simply doesn`t get created and i get no ip.

what can i do?

As addition i can issue AT Commands with no problem.

Another user has just created a thread and complains about problems with LTE and QMI.

Is there a serious problem with QMI in the new release?

Really no one having an idea whats wrong?

i also rebuilt now several times with the imagebuilder.
no luck


What Openwrt version are you using?
Have you set /sys/class/net/$ifname/qmi/raw_ip to Y?
cat /sys/class/net/$ifname/qmi/raw_ip

i'm using master branch for imagebuilder.

ls /sys/class/net/
br-lan   eth0     eth2     gretap0  wlan0
erspan0  eth1     gre0     lo       wwan0

the cat command says:

cat /sys/class/net/wwan0/qmi/raw_ip
cat: can't open '/sys/class/net/wwan0/qmi/raw_ip': No such file or directory

Which means that you aren't using the qmi_wwan driver. My guess is that the modem is in MBIM mode. So that explains your problem. Don't try to use uqmi with MBIM modems....

Yes, I see that you get QMI replies. This is a known problem. The modem autodetects the management protocol based on what it sees first. So if you try to talk QMI to it, then it will talk QMI back. The problem is that this is completely disconnected from the framing, so it won't work. You can't use MBIM framing with QMI management.

Either change modem to QMI mode or change your configuration to use MBIM.

Hy @bmork modem was indeed in mbim mode.. really dont know why..

i changed it with these command:


now im in QMI mode.


Config Index: 1
Config Type:  1 (Generic)
Interface bitmask: 0000050D (diag,nmea,modem,rmnet0,rmnet1)

but it didn`t really changed the behavior.

No Connection. No Virtual Interface.


root@OpenWrt:/# cat /sys/class/net/wwan0/qmi/raw_ip

is now also set or better said was set automatically

Some AT Info:


Index, Name,                        GW Band Mask     L Band Mask      TDS Band Mask
00, All bands,                      0002000007C00000 00000100130818DF 0000000000000000

Current Time:  829              Temperature: 38
Reset Counter: 1                Mode:        ONLINE
System mode:   LTE              PS state:    Attached
LTE band:      B3               LTE bw:      20 MHz
LTE Rx chan:   1300             LTE Tx chan: 19300
EMM state:     Registered       Normal Service
RRC state:     RRC Idle
IMS reg state: No Srv

PCC RxM RSSI:  -57              RSRP (dBm):  -85
PCC RxD RSSI:  -63              RSRP (dBm):  -90
Tx Power:      --               TAC:         36B0 (14000)
RSRQ (dB):     -7.8             Cell ID:     01198F0C (18452236)
SINR (dB):     18.4

 preferred fw version:
 preferred carrier name:  GENERIC
 preferred config name:   GENERIC_002.072_000
 preferred subpri index:  000
 current fw version:
 current carrier name:    GENERIC
 current config name:     GENERIC_002.072_000
 current subpri index:    000

Ok Guys.

I feel dumb :joy:

For everyone having the same issue:

My Provider had these APN setting on their webpage:

APN: "some apn"

User: None

Password: None

Because User and Password where "None" I choose Authentication: None

Which was wrong.

I had to choose:

Authentication : PAP/CHAP

And leave user and password empty.

Also, I had to choose


That did the trick.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.