Maximum number of networks on radio1

Hello. I want to implement a wireless network over a restaurant area. Each table has its own network (IP range) so I will be able to find out the table number by its IP range, after the customer joins to one of those networks.
What I have done yet:
network (devices):

config device
	option type 'bridge'
	option name 'wlan0.1'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:01'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'wlan0.2'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:02'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'wlan0.3'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:03'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'wlan0.4'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:04'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'wlan0.5'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:05'
	option ipv6 '0'
	
config device
	option type 'bridge'
	option name 'wlan0.6'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:06'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'wlan0.7'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:07'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'wlan0.8'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:08'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'wlan0.9'
	list ports 'wlan0'
	option mtu '1500'
	option macaddr '00:00:00:00:00:09'
	option ipv6 '0'

network (Interfaces):

config interface 'table1if'
	option proto 'static'
	option device 'wlan0.1'
	option ipaddr '10.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '10.0.0.255'
	option type 'bridge'

config interface 'table2if'
	option proto 'static'
	option device 'wlan0.2'
	option ipaddr '20.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '20.0.0.255'
	option type 'bridge'

config interface 'table3if'
	option proto 'static'
	option device 'wlan0.3'
	option ipaddr '30.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '30.0.0.255'
	option type 'bridge'

config interface 'table4if'
	option proto 'static'
	option device 'wlan0.4'
	option ipaddr '40.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '40.0.0.255'
	option type 'bridge'

config interface 'table5if'
	option proto 'static'
	option device 'wlan0.5'
	option ipaddr '50.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '50.0.0.255'
	option type 'bridge'

config interface 'table6if'
	option proto 'static'
	option device 'wlan0.6'
	option ipaddr '60.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '60.0.0.255'
	option type 'bridge'

config interface 'table7if'
	option proto 'static'
	option device 'wlan0.7'
	option ipaddr '70.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '70.0.0.255'
	option type 'bridge'

config interface 'table8if'
	option proto 'static'
	option device 'wlan0.8'
	option ipaddr '80.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '80.0.0.255'
	option type 'bridge'

config interface 'table9if'
	option proto 'static'
	option device 'wlan0.9'
	option ipaddr '90.0.0.1'
	option netmask '255.255.255.0'
	option broadcast '90.0.0.255'
	option type 'bridge'

dhcp:

config dhcp 'table1DHCP'
	option interface 'table1if'
	option start '10.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

config dhcp 'table2DHCP'
	option interface 'table2if'
	option start '20.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

config dhcp 'table3DHCP'
	option interface 'table3if'
	option start '30.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

config dhcp 'table4DHCP'
	option interface 'table4if'
	option start '40.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

config dhcp 'table5DHCP'
	option interface 'table5if'
	option start '50.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

config dhcp 'table6DHCP'
	option interface 'table6if'
	option start '60.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

config dhcp 'table71DHCP'
	option interface 'table17f'
	option start '70.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

config dhcp 'table8DHCP'
	option interface 'table8if'
	option start '80.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

config dhcp 'table9DHCP'
	option interface 'table9if'
	option start '90.0.0.2'
	option limit '250'
	option leasetime '2h'
	list ra_flags 'none'

wireless:

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table1'
	option encryption 'none'
	option network 'table1if'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table2'
	option encryption 'none'
	option network 'table2if'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table3'
	option encryption 'none'
	option network 'table3if'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table4'
	option encryption 'none'
	option network 'table4if'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table5'
	option encryption 'none'
	option network 'table5if'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table6'
	option encryption 'none'
	option network 'table6if'
	
config wifi-iface 'wifinet6'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table7'
	option encryption 'none'
	option network 'table7if'

config wifi-iface 'wifinet7'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table8'
	option encryption 'none'
	option network 'table8if'

With these configs I will have 8 SSIDs and they will just work fine (give a correct IP range to the clients).
Problem:
If i add another wifi-iface it will appear as disabled one.
Is there any some kind of limitation on wifi-ifaces? I want these network serves more than 8 tables!
wireless:

config wifi-iface 'wifinet8'
	option device 'radio1'
	option mode 'ap'
	option ssid 'table9'
	option encryption 'none'
	option network 'table9if'

Screenshot after added above part:

P.S: IP ranges are not final they are for test purposes only.
Thank you in advanced.

Use private IP addresses, like 10.0.1.0/24 for table1, 10.0.2.0/24 for table2 etc.
The first address is declared wrongly, use option start '2'

iw list and check the section valid interface combinations:

1 Like

My first tought is that this is a very complex config and very inefficient.
One interface can easily handle at least 255 IP leases just in the last byte.
Isn’t it easier and more efficient to use some kind of radius solution to handle the IP leases?

1 Like

Honestly I do not get the reason for that many networks. I do not understand why this is needed or desired.
Is it to separate all the clients, which can be done easily with the flag "isolate clients" ?
I mean I do not have a separate wifi SSID for every room of my house...

2 Likes

Thank you all.
I told addresses are not final :wink:
I'll change them after i do network segmentation.

valid interface combinations:
* #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 8,
total <= 8, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }
So it could not handle more than 8 ?
Disappointed!
Because the customers is unknown, I can't manage them and their table number. The only way i have thought is this ip ranges.

And how will you make sure that customer in table 1 is not connecting to table2 SSID?

1 Like

They will connect to network via QR code printed on their tables.

And how do you reassure that they won't connect using the QR code from another table?

2 Likes

Are you sure you aren’t confused about the difference between radio channels and actual IP leases per ssid?

The amount of leases are more about how many Mbits everyone are going to have. The access point separates the clients by mac address and IP number and give everyone different crypto keys (if you use secured wifi). The clients are not separated by radio channels.

1 Like

Because they do not want to pay for others bill :)).
Big picture:
you as a customer came to my restaurant and sat behind a table, scanned the QR then joined to network, our menu will appear on your device (via wifi splash or captive portal which not implemented yet) you will choose your dish and then make an order on that meanwhile in the kitchen i will receive your order and your table number and.....
any better idea?

But then you already have a radius server setup!?

let me ask in other way:
How can I find out the table number from a connection?

In hotels you often login to wifi with your name and room number or booking reference.

1 Like

No.
there is no need. Because i have nothing from my customers (mac, IMEI, Device name ,....). I have no control over their actions too (so i will implement wifi splash or cp for them to accessing my menu)

Yes that is an option, but it will be my last solution. Simpler is better :upside_down_face:

If every table has a different qr-code every table qr code could point to a different web-site, or to a web-site where the table number is a parameter as specified in the qr code... something like this should be possible.

I never would use different SSIDs to achieve this. Also the different SSIDs do not bring in any additional safety. It is just that a feature is used in a way it was never meant to be used for.

1 Like

Sure, but as for a business restaurant solution. You talk about a complete order, service and payment system integrated in the table placement and business model.

I can’t see why you don’t buy a commercial business solution for this?

1 Like

The QR code i mentioned before was a WiFi QR code (Somthing like WiFi QR Code.
they will all route to one and unique page.

They can still mess up your restaurant if some malicious user connects to another table and starts ordering for that table.
The segregation you are trying to do doesn't help at all, it makes things more complicate.
If you are going to let customers order by themselves whatever they want, you'd have to have some reassurance first. For example they connect to the webpage of the restaurant, enter table and credit card details and then they can order.

3 Likes

Because its a personal project only for fun and I fall in love with OpenWRT :grinning:.
P.S: all this happening on the local network (Openwrt as a AP, Web server, Media ,....). without any internet.