Maximize OpenWRT performance on Linksys E8450

Hi,

I'm currently having a performance issue with Linksys E8450.
Here's my hardware configuration.

Huawei GPON Terminal (A) -> Linksys E8450 (B) -> wired connection -> (C) TPLink TL-SG105 5-port switch -> clients (D)
With this configuration, a wired connection at point D gets about 87 - 90 Mbps both download (DL) and upload (UL) speed.

However, when I tested the following configuration, bypassing the Linksys router completely:
Huawei GPON Terminal (A) -> wired connection to laptop, I get about 492.4Mbps DL and 407.0 Mbps UL speed.

The above configuration is not suitable, since I require more than 1 wired connection, hence the router.

So, even if I bypass the switch and place a client connection directly at point (C), I'm still getting somewhere < 100 Mbps (between 70 - 90Mbps).

What configuration do I need to set for OpenWRT so that it can run at maximum performance?
Happy to send existing configuration files, just lemme know what's needed.

I'm using OpenWRT SNAPSHOT r19191-9024f1e466 / LuCI Master git-22.083.68981-15bbe69

I tried iperf3, and here's my results from the client on point D.

[  4] local 192.168.1.2 port 55162 connected to 192.168.1.1 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  11.4 MBytes  95.5 Mbits/sec
[  4]   1.00-2.00   sec  11.3 MBytes  94.6 Mbits/sec
[  4]   2.00-3.00   sec  11.3 MBytes  94.7 Mbits/sec
[  4]   3.00-4.00   sec  11.3 MBytes  94.6 Mbits/sec
[  4]   4.00-5.00   sec  11.3 MBytes  94.9 Mbits/sec
[  4]   5.00-6.00   sec  11.3 MBytes  94.8 Mbits/sec
[  4]   6.00-7.00   sec  11.3 MBytes  94.9 Mbits/sec
[  4]   7.00-8.00   sec  11.3 MBytes  94.8 Mbits/sec
[  4]   8.00-9.00   sec  11.3 MBytes  94.8 Mbits/sec
[  4]   9.00-10.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  10.00-11.00  sec  11.3 MBytes  94.7 Mbits/sec
[  4]  11.00-12.00  sec  11.3 MBytes  94.8 Mbits/sec
[  4]  12.00-13.00  sec  11.3 MBytes  94.5 Mbits/sec
[  4]  13.00-14.00  sec  11.3 MBytes  94.8 Mbits/sec
[  4]  14.00-15.00  sec  11.3 MBytes  94.8 Mbits/sec
[  4]  15.00-16.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  16.00-17.00  sec  11.3 MBytes  94.7 Mbits/sec
[  4]  17.00-18.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  18.00-19.00  sec  11.3 MBytes  94.8 Mbits/sec
[  4]  19.00-20.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  20.00-21.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  21.00-22.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  22.00-23.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  23.00-24.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  24.00-25.00  sec  11.3 MBytes  94.9 Mbits/sec
[  4]  25.00-25.84  sec  9.46 MBytes  94.9 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-25.84  sec  0.00 Bytes  0.00 bits/sec                  sender
[  4]   0.00-25.84  sec   292 MBytes  94.8 Mbits/sec                  receiver
iperf3: interrupt - the client has terminated

The rate measured by iperf3 seems to point to something, since my network cables are capable of 1Gbps, and supposedly TPLink TL-SG105 is capable of 2Gbps.

Thank you.

I did not read through you post carefully. Are you experiencing this bug? I believe you must be using VLAN filtering and having wired devices:

I don't think I have VLAN filtering.
I'm not sure what the below shows.
Can you tell me if I have VLAN enabled?

I do see the 100FD below lan1. I wonder if that's limiting my speed somehow.

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda0:d71e:7e41::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option mtu '1472'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option name 'eth0'
        option mtu '1472'
        option mtu6 '1472'