Massive packet drops when using LEDE/OpenWRT on my router

I currently have a BTHub5-3CMJ (ISP router) setup as a "modem" due to the fact that my internet is on a VDSL and not ADSL connection (i.e. I can't just use any old modem) and also because I am wanting to save money. To that I have hooked a Linksys 1900acs v1. Using just the ISP router as a router, I get my normal 50mbps down, 10mbps up. I then disable dhcp (tried this with dhcp on as well btw) and wifi etc on the BTHub and hook up the Linksys as the sole device using a static ip. I then setup wifi on the linksys leaving all other settings at stock (I have tried this with and without upgrading packages through opkg). It works fine for 3-4 days, but then on the "modem" I start getting this error (at very close intervals):

OUT: BLOCK [7] ICMP replay (ICMP type 3 code 1(or 3 sometimes) "router ip"-​>"dest. ip" on ppp3)

This also happens to somehow throttle down my internet to the barely usable speeds of <1mbps down and <0.5mbps up.

I gathered that this probably has something to do with the firewall on the BTHub, so I "disable" that. I put disable into quote marks as that literally did nothing at all. I then proceed to move the router into dmz on the BTHub. Still no change.

I then googled the issue, and it seems to be a long-running problem with BTHub5's however I have yet to find a solution that works for me.

In LEDE itself (after enabling logging dropped packets), I see this error pop up literally every second:

Sat Oct 14 15:24:50 2017 kern.warn kernel: [16444.671848] MSSFIX(wan): IN=br-lan OUT=eth1 MAC="mac address" SRC="src_ip" DST="dst_ip" LEN=60 TOS=0x00 PREC=0x00 TTL=63 ID=34077 DF PROTO=TCP SPT=42981 DPT=8080 WINDOW=13600 RES=0x00 SYN URGP=0

So I'm coming here to ask if there is anything that I could try inside LEDE to try to fix this, just to work out whether LEDE isn't properly configured or whether the BTHub is at fault and I should get an actual modem as I don't want to cash out money just to find out that it has fixed nothing.

Just my two pennies worth. With the equipment you have, there are only two ways of connecting them together:

Linksys as Wireless Access Point.

Home Hub 5 as main router - DHCP on. Turn off Wifi.

WRT 1900ac - using default LAN IP Turn off DHCP server.
Wire any LAN socket (not internet WAN) from WRT1900ac to any LAN socket on Home Hub.

Double NAT router mode

Home Hub 5 as router ( - DHCP on. Turn off Wifi,

WRT 1900ac as router. DHCP on. Change LAN Interface IP address from default to something like Ensure WAN interface is using DHCP-client protocol. Wire yellow internet WAN socket to any LAN socket on Home Hub.

Personally, I recommend you simply replace the Home Hub with a VDSL2 bridge modem, such as an used Openreach Huawei HG612 (type 3B) or less popular ECI model. TPlink TD-W9970 VDSL modem router is readily available from local Argos also has a bridge mode. Then configure WRT1900ac to use PPPoE protocol on its WAN interface wired to the bridge modem.

1 Like

Or you could just install LEDE on the HomeHub5, assuming it is type 5a... and you did not rent the home hub... But you still could buy a homeHub5a that runs lede and either use it as your router or configure it to act as bridged modem.

Best Regards

Thanks for the replies :slight_smile:

I guess I’ll just replace the BTHub5 with an actual modem for it just as that is probably the simplest option.

Many thanks,