MAP-T Configuration - desperate for some help

Hi all,

I'm new to OpenWRT and trying to configure MAP-T CE based on the below parameters I have from the BR:
dmr-prefix 3001:db8:ffff::/64
ipv4-prefix 192.0.2.0/24
mapt-prefix 2001:db8:ce::/48

After days of trying, I give up and hope someone can help please.
Thanks in advance!

Below is the network configuration as well of some output:

root@OpenWrt:~# route -A inet
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.1.152.0      *               255.255.255.0   U     0      0        0 br-mgmt
1.129.224.0    *               255.255.255.252 U     0      0        0 eth0
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan

root@OpenWrt:~# route -A inet6
Kernel IPv6 routing table
Destination                                 Next Hop                                Flags Metric Ref    Use Iface
2001:db8:ce::/48                            ::                                      U     1024   2        0 br-lan  
2620:103:c00a::/126                         ::                                      U     256    1        0 eth0    
fdc8:1f8e:fc28::/48                         ::                                      !n    2147483647 2        0 lo      
fe80::/64                                   ::                                      U     256    1        0 br-lan  
fe80::/64                                   ::                                      U     256    1        0 eth0    
::/0                                        2620:103:c00a::1                        UG    1024   3        0 eth0    
::1/128                                     ::                                      Un    0      5        0 lo      
2620:103:c00a::/128                         ::                                      Un    0      3        0 eth0    
2620:103:c00a::2/128                        ::                                      Un    0      4        0 eth0    
fe80::/128                                  ::                                      Un    0      3        0 br-lan  
fe80::/128                                  ::                                      Un    0      3        0 eth0    
fe80::250:ff:fe00:b00/128                   ::                                      Un    0      3        0 eth0    
fe80::250:ff:fe00:b01/128                   ::                                      Un    0      4        0 br-lan  
ff00::/8                                    ::                                      U     256    4        0 br-lan  
ff00::/8                                    ::                                      U     256    1        0 eth0    
::/0                                        ::                                      !n    -1     1        0 lo      
root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc8:1f8e:fc28::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'
        list ports 'eth2'
        option ipv6 '1'

config device
        option name 'br-mgmt'
        option type 'bridge'
        list ports 'eth4'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        list ip6class 'wan6'

config interface 'mgmt'
        option device 'br-mgmt'
        option proto 'static'
        option ipaddr '10.1.152.101'
        option netmask '255.255.255.0'
        list dns '10.85.6.68'
        option delegate '0'

config device
        option name 'eth0'
        option mtu '9152'
        option ipv6 '1'

config interface 'wan'
        option proto 'static'
        option device 'eth0'
        option ipaddr '1.129.224.2'
        option netmask '255.255.255.252'

config interface 'wan6'
        option proto 'static'
        option device 'eth0'
        option ip6gw '2620:103:c00a::1'
        list ip6addr '2620:103:c00a::2/126'

config route6
        option interface 'lan'
        option target '2001:db8:ce::/48'

config route
        option interface 'mgmt'
        option target '0.0.0.0/0'
        option gateway '10.1.152.1'
        option disabled '1'

config interface 'mapt'
        option proto 'map'
        option maptype 'map-t'
        option peeraddr '3001:db8:ffff::/64'
        option ipaddr '192.0.2.0'
        option ip4prefixlen '24'
        option ip6prefix '2001:db8:ce::'
        option ip6prefixlen '48'
        option ealen '16'
        option psidlen '8'
        option offset '4'
        option force_link '1'
        option tunlink 'wan6'

config route
        option interface 'mapt'
        option target '0.0.0.0/0'
        option onlink '1'
        option gateway '0.0.0.0'```