Manually add new network adapter

Hello,

this OpenWrt installation is running on ESXI.
I want to create a network for rogue vm's and allow only DHCP and RDP traffic those vms

so far I added a new adapter to the OpenWrt vm.
I created a new Interface but when this new interface is started the internet stops working

thanks

root@OpenWrt:~# uci export network
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd17:5726:3a19::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.1.1.1'
	option ipv6 '0'

config interface 'wan'
	option proto 'pppoe'
	option username 'user'
	option password 'pass'
	option ipv6 '0'
	option device 'eth1'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config interface 'docker'
	option device 'docker0'
	option proto 'none'
	option auto '0'

config device
	option type 'bridge'
	option name 'docker0'
	option bridge_empty '1'

config device
	option type 'bridge'
	option name 'br-7a591e91523a'
	option bridge_empty '1'

config device
	option type 'bridge'
	option name 'br-09996da2c762'
	option bridge_empty '1'

config device
	option type 'bridge'
	option name 'br-116592dc90de'

config interface 'brmydocker'
	option device 'br-8310920577ed'
	option proto 'none'
	option auto '0'

config device
	option type 'bridge'
	option name 'br-8310920577ed'

config device
	option type 'bridge'
	option name 'br-f285797cb00e'

config device
	option name 'eth2'

config interface 'Quarantine'
	option device 'eth2'
	option proto 'static'
	list ipaddr '10.2.1.1'

Adding a new virtual adapter in the hypervisor doesn't necessarily mean that it will enumerate last (eth2 in this case) in the OpenWrt kernel. It may end up replacing one of the other ones. The order will remain consistent once it is established.

Also you need to specify the subnet size of the quarantine network, such as 10.2.1.1/24 or netmask '255.255.255.0'

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.