Management Frame Protection Optional not working

Hello,

After migrating to OpenWrt one(only one) of my devices failed to connect. After disabling "802.11w Management Frame Protection" The device was able to connect again.

But when set to optional, The device fails to connect. So at this point I'm wondering if optional works the same as required?.

I think enabling 802.11w would be a good thing, but now I can't because of one device.
Is it possible to make this really optional or is the issue in this specific device?

This option also doesn’t work well on other firmware - for example, it is recommended that the option be disabled even on the standard unifi firmware. It is more of a sta (client) side issue that is at play here - similar to how some devices don’t play well with wpa2/3 mixed mode operation.

It is an all-or nothing control (off, optional, required) - you cannot make per device decisions.

1 Like

The issue is the client. What is the one client? I found that a Raspberry Pi 4 in client mode will not connect at all with an AP set to optional.

1 Like

thank you both,

I will leave this option disabled for then for 2.4G. 5Ghz devices then still can benefit from this feature.
I also use wpa2/3 mixed mode but so far no issues. but good to know it some issues occur in the future.

I have the issue with my Bosh dishwasher from 2021. Strange enough, I don't have any issues with my Bosch Laundry machine.