Manage Openwtr on a m5 litebeam antenna

I recently flashed my litebeam antenna with Openwtr v19.07.10.

The only problem I have so far is that I can't manage the antenna when it's connected to the router, it's only possible to do it when I connect the lan cable directly to my pc.

I am using the antenna to link another receiving antenna in client ad-hoc mode.

I'm just learning about network connections, I've tried Port Forwarding, but I really have no idea how to make this work.

Neither do we, it depends on how they're interconnected...?

1 Like

Let me see if I can explain well:

I have my main router connected directly to the internet provider, on the router there is a lan port used for the antenna and another for the pc. The antenna sending internet to another receiving antenna (point to point link I think).

But there is no way to access the openwrt gui interface, neither from my pc nor by connecting to the wifi network of the transmitting antenna (remember that openwrt is installed on the antenna, not on the router).

Assuming you have two Litebeams with OpenWrt installed, the one connected to your router the source of Internet should be configured as an AP(WDS) while the one receiving the signal will be STA(WDS).

These wifi interfaces should be bridged into the existing lan network in OpenWrt. This situation will extend the house router's network to the remote location equivalent (of course not as fast) as if there were an Ethernet cable.

In both cases set the lan network as dhcp client so that it receives a dhcp IP from the router.

I think this is the same hardware platform as the Nanostation M5 loco XW and thus it might be able to run that 22.03 build. Or it could brick.

I think this is the same hardware platform as the Nanostation M5 loco XW and thus it might be able to run that 22.03 build. Or it could brick.

Wow I would like to do the experiment, where can I get that build?.

I bring very good news!, I updated to wrt-22.03.5 and everything seems to work fine. :smiley:

File: openwrt-22.03.5-ath79-generic-ubnt_nanostation-loco-m-xw-squashfs-sysupgrade.bin


There is a big problem, the data is not being saved and every time I restart all the values return to default. :frowning:

I think I saw something about a bug in 22.03.5 causing that on certain Ubiquiti, you may want to try 22.03.3 instead.

Log in by ssh and run mount to make sure overlay is mounted on a jffs (not tmpfs) read write.

Log in by ssh and run mount to make sure overlay is mounted on a jffs (not tmpfs) read write.

Look at this:

root@OpenWrt:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /tmp/root type tmpfs (rw,noatime,mode=755)
tmpfs on /dev type tmpfs (rw,nosuid,noexec,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,noatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,noatime,mode=700)
/dev/mtdblock5 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)

As for openwrt v19.07, I tried to test it but the results were terrible. For a few moments it works but suddenly my entire home network becomes unstable and the internet goes down completely.

I also confirm the same problem with 22.03.3 I'm afraid.

Also in both cases flash image does not work (at least not from Luci)

And for some reason the system packages does not show the size or description:

When you upgraded, did you keep settings or did you reset to defaults?

In my last tests I flashed the images using tftp , so it should be a clean install.

I don't think this is a problem (or if it is, it is unrelated to your issue)... I'm seeing the same thing (no size or description for installed packages) and I'm on a Ubiquiti RouterStation Pro with 22.03.5.

You seem to have enough space to ensure that files get saved. How are you changing the configuration? If you're using the UCI commands on the CLI, are you commiting the settings?

Also, a quick test you can run to ensure that the files are being saved...

touch ~/test.txt

if file survives a reboot, the issue is probably not that files aren't being written/saved, but that something may not actually committing the config changes.

That will happen if you made a network loop by connecting both units to the home router by cable. Once you have the second unit set up to be a client of the first, connect it only to a power injector don't connect the Ethernet back to the home router. You'll be linked to it wirelessly. When the client unit is operating in the remote location, endpoint devices can connect to its Ethernet port on the power injector.

When there is a network loop, packets will go around and around the loop (wired to wireless back to wired in this case) endlessly and amplify until the whole network is DoS'd.

This is not the case, since it is an external antenna that only has 1 lan port, there is no way to return a second cable to the home router.

Is there any possible return path or loop anywhere at all? A loop within the network on the other side would have the same impact, even if it doesn't tie directly back to the main router.

1 Like

I must check this.

Even so I did a test removing the luci software packages, then the web interface changed to a simple mode (as if it had no css) then I rebooted and the behavior did survive. After this I did a factory reset and the luci interface returned to normal.

Apparently when removing software packages the changes are maintained.

How exactly did you do this? Did you build a custom image? or did you use the opkg remove function?

On the other side of the network there is an external antenna receiving the signal from my transmitter antenna (where I am testing openwrt), this antenna supplies the internet to a home router.
Basically I have not modified the configurations of the equipment on the other side of the network, and these have worked normally when openwrt is not installed.

I did many tests combining all the configurations that occurred to me but in the end nothing worked for me to keep the network stable.

If I set the lan adapter to static, then there is no internet on the wifi network.

If I set the adapter to automatic, then it works until it destabilizes and the internet goes down completely.

Let's see a diagram of your topology. A photo of a sketch on paper is sufficient. Be sure to indicate all of the infrastructure devices, their brand/models and the firmware/OS, the ports involved (particularly if there are wan and lan ports), and the IP addresses of each device.