Make LuCI accesible over WiFi in repeater mode


I've set up my Netgear DGN2200 as Wireless Extender using USB WiFi long range antenna.I made a clean install of 19.07 and then configured it using this tutorial. The only difference was that I use USB antenna to connect to other network and router's built in to transmit signal.

1.) I'd like to be able to use LuCi over Wifi network. Currently my main router that is connected to the Internet has admin panel address: so I'm not able to open LuCi on that address through WiFi. Is there any way to change LuCi's IP and be able to acces it through WiFi?

2.) How to enable Internet connection on ethernet ports on my DGN2200? I can only acces LuCi when connected via ethernet to my Netgear router and it says there's no Internet connection.

There is no separate LuCI IP. LuCI (or actually uhttpd, the web server packages) is just running in the router and reachable at the router's IP address. Quite similarly as the SSH console. (if you can reach the SSH console, LuCI should be in the same address)

If you have several routers, it is upto you to config the addresses in them so that you can reach the admin with SSH (and LuCI).

So where in configuration should I change IP so that router will be available on that new IP address?

In the LAN interface settings (where you already should have changed the address, as your main router also has and this OpenWrt router also defaults to that.)

I set up my LAN interface like this

Also without IPv4 gateway and Custom DNS and I wasn't able to connect to my router on
What else should I change?

That looks ok, and you are able to connect to LuCI GUI at
Assuming that you are normally connecting it to the main router via LAN port (or wds), you should be able to reach this this router

You have set the router to the router to the same 192.168.1.x subnet as the main router, which is normally correct for a secondary router, assuming that the .42 router does not try NAT (so that there is no double NAT) connecting to the main router via wan port.

Have you checked OpenWrt wiki? It has recipes for several types of dumb APs and repeaters. The info there might help you to debug more detailedly.

For anybody to be able to give detailed advice, you should provide more details about network and WiFi settings on both routers. (Not screenshots, but the uci config files).

Here is my config: My main router is Orange FunBox so it has its own OS.
After changing IPv4 to and waiting 80 seconds I was not able to open LuCi or connect via SSH with router connected in both configurations: to Wifi only and via ethernet to my PC.
I tried multiple times and also tried and it wouldn't connect. After each try I had to reset router to be able to connect on again.

First problem is solved. I had to set IPv4 on my PC when connected via ethernet to instead of