Major performance regression


I've upgraded my PC-Engines APU-3 router from 19.07.7 to 21.02.1 (both x86-64) and I'm seeing a major performance regression.

On the old version I could get to 1Gbps line-speed, but on the new version I can't even make half that.

Also tried upgrading to 19.07.8 and even that small upgrade shows a performance regression, though not as bad: I can no longer reach line-speed but at most up to 900Mbps.

I'm seeing just a single CPU loaded on the new version, while on the old version the load is distributed over multiple CPUs.
My internet is on a VLAN.
I have a few forwarded ports.

I've tried many many things, even setting all CPUs to the performance govenor, but I've gotten no further.

Any recognition or tips?

When going from 19.0x to 21.02.x, reconfig from scratch.

I tried that too. No difference

Have been struggling with it all day today, and got more info when looking at the CPU loads

Looks like the APU-3 isn't supported on 21.02.1

The correct page suggests otherwise :stuck_out_tongue:

Iirc software flow offloading is disabled by default in 21.02 releases due to IPv6 brokeness, maybe this is causing your performance degration?

SW offloading is/was not enabled.

Looks like some documentation updating/cleanup is needed.

Also in 19.x? Well then I can only guess that maybe some kernel issue crept in. The fact that only one core is utilized compared to all cores on 19.x sounds like a kernel misconfiguration or something.

Unless something else is enabled like QoS/shaping?

No QoS is enabled, that only makes it worse (tried it though)

Can you please post output of:

cat /proc/interrupts
lscpu or cat /proc/cpuinfo

Unfortunately I've reverted the router back to 19.07.7

Just found out that the regression is in Firefox, not in OpenWRT (luckily, but still strange).
When I run the bandwidth check in Google Chrome everything is fine.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.