Mainline ath10k crash as soon as a device connects

Issue

Having an issue with mainline ath10k firmware and kmod
This does NOT happen when connecting to 2.4GHz (ath9K) or ath10k-ct firmware and kmod.

I am using the config files below.

As soon as I connect a STA to 5GHz (ath10k), AP restarts. All I see in log file is:

Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 IEEE 802.11: authentication OK (open system)
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 MLME: MLME-AUTHENTICATE.indication(04:f0:21:48:ae:d0,
OPEN_SYSTEM)
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 MLME: MLME-DELETEKEYS.request(04:f0:21:48:ae:d0)
Wed Aug  7 02:02:35 2019 daemon.info hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 IEEE 802.11: authenticated
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 IEEE 802.11: association OK (aid 1)
Wed Aug  7 02:02:35 2019 daemon.info hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 IEEE 802.11: associated (aid 1)
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 MLME: MLME-ASSOCIATE.indication(04:f0:21:48:ae:d0)
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 MLME: MLME-DELETEKEYS.request(04:f0:21:48:ae:d0)
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 IEEE 802.11: binding station to interface 'wlan0-ap'
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 WPA: event 1 notification
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 WPA: start authentication
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 IEEE 802.1X: unauthorizing port
Wed Aug  7 02:02:35 2019 daemon.debug hostapd: wlan0-ap: STA 04:f0:21:48:ae:d0 WPA: sending 1/4 msg of 4-Way Handshake

Installed ath10k and ath9k versions

kernel - 4.14.134-1-233e5e02ef5e2b2e5ffd578903c35ca8
ath10k-firmware-qca9984 - 20190618-1
kmod-ath - 4.14.134+5.2-rc7-1-1
kmod-ath10k - 4.14.134+5.2-rc7-1-1
kmod-ath9k - 4.14.134+5.2-rc7-1-1
kmod-ath9k-common - 4.14.134+5.2-rc7-1-1

/etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    list   network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'

config include
    option path '/etc/firewall.user'

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd11:bfbc:c18c::/48'

config interface 'service'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.100.1'
	option netmask '255.255.255.0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'private'
	option auto '1'
	option proto 'none'
	option type 'bridge'
	option ifname 'eth1.3'

config interface 'guest'
	option auto '1'
	option proto 'none'
	option type 'bridge'
	option ifname 'eth1.4'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '1t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '1t 6t'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option country 'US'
	option hwmode '11a'
	option htmode 'VHT40'
	option channel '36'
	option txpower '13'
	option basic_rate '12000 18000 24000 36000 48000 54000'
	option supported_rates '12000 18000 24000 36000 48000 54000'
	option log_level '3'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/qca955x_wmac'
	option country 'US'
	option hwmode '11g'
	option htmode 'HT20'
	option channel '11'
	option txpower '13'
	option basic_rate '12000 18000 24000 36000 48000 54000'
	option supported_rates '12000 18000 24000 36000 48000 54000'
	option log_level '3'

config wifi-iface 'wlan0_ap'
	option mode 'ap'
	option device 'radio0'
	option network 'private'
	option ifname 'wlan0-ap'
	option ssid 'xxx'
	option encryption 'psk2'
	option key 'xxx'

config wifi-iface 'wlan1_ap'
	option mode 'ap'
	option device 'radio1'
	option network 'private'
	option ifname 'wlan1-ap'
	option ssid 'xxx'
	option encryption 'psk2'
	option key 'xxx'

Please let me know if any other information is needed.

Thanks :slight_smile:

That is a known issue, see

@slh Oh no :frowning:

Thanks for links to bug reports. I'll keep using ath10k-ct and wait for the fix since I don't know much about how to fix this issue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.