MAC override does not work

I have a problem with my WNDR 3700v4 router. Last night i build openwrt for it. I usualy just save settings and do upgrade, but this time i had problem. It did not connect to the internet. I reseted settings but still it did not work. My WAN interface is etc0.2 I tracked down the problem. It does not override mac address which needs to be as my old PCs. My 7$ Tenda router can clone/override mac with JUST one click and this fancy super powerfull router compared to that tenda, with this superpowerfull software like openwrt can't do as little thing as overriding mac address? Can you help me with this problem. For now i have disabled DHCP on openwrt router and connected it's lan port to tendas lan port to have WIFI. I removed wifi cable and antenna from tenda and attached it to my drones remote controll. I just want to have this openwrt because i use many services. Openvpn network, VPNbypass, DNScrypt proxy, transmission and so on. I really need this openwrt router.

i believe a simple hand edit can fix as per:

also try releasing ip prior to powering down old router and wait 10 mins before powering up new one.

isp's dont like to issue two addresses at the same time!

I tried editing by hand. In fact i did it in first place. option macaddr 'XX:XX:XX:XX:XX:XX' did not work. Then i tried from LUCI and it did not work either.

Try this method in the interim maybe?

so i came across the gotcha ( gotme ) from last time;

-make sure that the parameter is applied to the "correct" section in /etc/config/network

there is some variance in this between releases and builds but more recent ones seem to apply it under;

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option delegate '0'

when it should be;

config device 'wan_dev' < **HERE**
	option name 'eth0.2'
	option macaddr '00:80:6E:77:77:7X'

Still not working. In LuCi forum says that this is OpenWRT bug. From LuCi you edit "INTARFACE" but not "DEVICE". Why OpenWRT inores interface settings for MAC? It is very inconvenient each time when updating to manually add a line to the 'wan_dev' section. Please, fix it already ... is it really so difficult?

1 Like

I'm somewhat lost, I can successfully change my WAN MAC here:


Perhaps an issue on certain models?

You are aware there's a brief time where there's an ARP conflict - that you must resolve on some connections, correct?

I got it working. Luci is not writing in config files. I change something click save and apply but it does not write into config file. I recreated my config from config files manually and everything works again.

You were right! I do not know why they do not fix it already. Because of that very usefull feature like mac override does not work. But for me luci does not even write some changes to config files. I have to edit config files manually.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.