Mac address on Checkpoint L50

Hi,
I got a Checkpoint L-50 and ready to flash openwrt on the device but a bit of confusion in relation to mac address -

I am following the guide here in forum. managed to do the original fimware backup and get the exisiting mac address.

The original mac address as on the device with original checkpoint fimware are as follows -
eth0 00:XX:XX:XX:XX:8E WAN
eth1 00:XX:XX:XX:XX:8F LAN 1
eth2 00:XX:XX:XX:XX:97 DMZ
eth3 00:XX:XX:XX:XX:90
eth4 00:XX:XX:XX:XX:91
eth5 00:XX:XX:XX:XX:92
eth6 00:XX:XX:XX:XX:93
eth7 00:XX:XX:XX:XX:94
eth8 00:XX:XX:XX:XX:95
eth9 00:XX:XX:XX:XX:96

refering to the [HOWTO] Installing OpenWrt on Check Point L-50

I don't know which is

setenv eth0addr 01:23:45:67:89:ab
setenv eth1addr 01:23:45:67:89:ac

in reference to the mac address I captured.

Pls note my checkpoint does not have WLAN or DSL port. It has 8 x LAN ports, 1 x DMZ port and 1 x WAN port.

So what mac address should I set for eth0addr and eth1addr ???

Appreciate any help.

These are made up Mac addresses. Use the addresses you observed on your device ports.

OK
so eth0 is WAN mac as shown above in my msg
i.e xxxxxxxxx8E - WAN
and
eth1 is LAN1 mac as above, i.e xxxxxx8F LAN1

am I correct.
Sorry for the trouble but just trying to remove my confusion.

That sounds correct, yes.

setenv wan_mac_addr XX:XX:XX:XX:XX:8E

setenv dmz_mac_addr XX:XX:XX:XX:XX:97

setenv lan1_mac_addr XX:XX:XX:XX:XX:8F

setenv lan2_mac_addr XX:XX:XX:XX:XX:90
setenv lan3_mac_addr XX:XX:XX:XX:XX:91

and so on

NEED HELP URGENTLY

I am flashing openwrt on checkpoint L50, I am flooiwng the process, after booting into openwrt I cannot get an ip address to my PC.
The erro is as follows -

lan1 : failed to open master eth1
br-lan: port 1 lan1 entered blocking state
device lan1 entered promiscuos mode

Any help PLEASE

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

I can't connect using ssh, current;y openwrt is running in the memory, I am yet to do the last part "sysupgrade"
Below out from openwrt console while running in RAM

root@OpenWrt:~# ubus call system board
{
	"kernel": "5.15.137",
	"hostname": "OpenWrt",
	"system": "Feroceon 88FR131 rev 1 (v5l)",
	"model": "Check Point L-50",
	"board_name": "checkpoint,l-50",
	"rootfs_type": "initramfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.2",
		"revision": "r23630-842932a63d",
		"target": "kirkwood/generic",
		"description": "OpenWrt 23.05.2 r23630-842932a63d"
	}
}



root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fddc:b803:f0b4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'
	list ports 'lan6'
	list ports 'lan7'
	list ports 'lan8'
	list ports 'dmz'

config interface 'lan'
	option device 'br-lan'
        option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
        option force_link '1'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0'
	option proto 'dhcpv6'



root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'



root@OpenWrt:~# cat /etc/config/firewall
config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

Remove the ifname line... that is invalid.

reboot and try again.

I cannot reboot as the system is residing in RAM, I will restart network. I hope this works.
As I said, I am in the middle of flashing the firmware and so not done the sysupgrade command

Also, I am doing the following is this correct or not

setenv eth0addr XX:XX:XX:XX:XX:8E

setenv eth1addr XX:XX:XX:XX:XX:8F

setenv lan1_mac_addr XX:XX:XX:XX:XX:8F

setenv lan2_mac_addr XX:XX:XX:XX:XX:90
setenv lan3_mac_addr XX:XX:XX:XX:XX:91
setenv lan4_mac_addr XX:XX:XX:XX:XX:92
setenv lan5_mac_addr XX:XX:XX:XX:XX:93
setenv lan6_mac_addr XX:XX:XX:XX:XX:94
setenv lan7_mac_addr XX:XX:XX:XX:XX:95
setenv lan8_mac_addr XX:XX:XX:XX:XX:96

setenv eth2addr XX:XX:XX:XX:XX:97`

I collected all mac adddress from the router when it was running the original Checkpoint firmware. I would prefer to leave DMZ mac seperate from the LAN.

I did this it didn't work

Can you please help

I am still having this problem

[quote="Aks, post:6, topic:199382"]
lan1 : failed to open master eth1
[/quote]

Pls help

It has been a while since I converted a L50 to OpenWrt but if you have completed step four from the instructions below you have written the new bootloader to flash. When you reboot you should be able to interrupt the new uboot during the first few seconds and continue from there.

https://openwrt.org/toh/check_point/l-50

The L50 is very forgiving since kwboot can always be used to get back in and flash new firmware.

I did follow the instructions as they are. The system boots, i don't get any ipaddress allocated to the client pc. BUT from the openwrt command prompt I can access the internet. Basically WAN works.

Here is the output of the error message.

 9.654352] kmodloader: done loading kernel modules from /etc/modules.d/*
[   24.888694] mv88e6085 f1072004.mdio-bus-mii:10 lan1: failed to open master eth1
[   24.913635] br-lan: port 1(lan1) entered blocking state
[   24.918922] br-lan: port 1(lan1) entered disabled state```

The environment setting is as follows -

NSA325> printenv
baudrate=115200
bootcmd=ubi part ubi; ubi read 0x800000 kernel; bootm 0x800000
bootdelay=3
console=console=ttyS0,115200
dmz_mac_addr=00:1C:7F:00:00:97
etha10ddr=00:1C:7F:00:00:8F
ethact=egiga0
ethaddr=00:1C:7F:00:00:8E
lan1_mac_addr=00:00:00:XX:00:8E
lan2_mac_addr=00:00:00:XX:00:90
lan3_mac_addr=00:00:00:00:00:91
lan4_mac_addr=00:00:00:00:00:92
lan5_mac_addr=00:00:00:00:00:93
lan6_mac_addr=00:00:00:00:00:94
lan7_mac_addr=00:00:00:00:00:95
lan8_mac_addr=00:00:00:00:00:96
mtdids=nand0=orion_nand
mtdparts=mtdparts=orion_nand:0x0c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)
stderr=serial
stdin=serial
stdout=serial

Environment size: 662/131068 bytes

I figured out the issue, it is related to the config file in openwrt firmware. I have a temp fix, but I want to know how to fix the issue permaneantely. I believe this can only be done by a system developer becaue the config file with error will be restored if system is restored to factory default.

I am having all interfaces being blocked in the same manor. How did you resolve?

Aplogogy for late response, I was in hospital.
This is what I did.

The issue was related to Uboot setting. Apparently, there is a setting called
Net - value "egiga0" and "egiga1"
0 is for eth0 and 1 is for eth1

If you send a screen shot or output of the error, it will be usefull.