M-Net Successful PPPoE Authentication but only Link-Local IPv6

Hey OpenWrt Community!

I have an FTTB subscription from M-Net (Munich, Germany) with GFast and DS-Lite. I use the Draytek 166 as a modem and the Banana PI R3 as a router.

The Draytek 166 has the latest STD firmware and is set up for GFast with VLAN ID 40.
I authenticate successfully with PPPoE to M-Net via WAN and receive a Link-Local IPv6 address (I verified this with a TCP Dump aswell), but I do not receive a global IPv6 address. I read in the M-Net forum that instead of an IPv6 address a prefix is given.

Has anyone had the same problem, or can someone help?

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'pppoe'
	option username 'xxxxx@mdsl.mnet-online.de'
	option password 'xxxx'
	option ipv6 '1'
	option device 'wan'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'
	option reqprefix 'auto'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

Hugo

Can you provide pcap from ll address acquisition? What exactly you saw in tcpdump?

Here the pcap. PPP Authentication was omitted.

ip6 was rejected within PPP, see pcap with wireshark or so.
it was meant to be tongue in cheek joke, because ll addresses are derived from local interface MAC addresses, and you see them mapping other local interfaces in the network later.
What you can try - use ppppoe-wan as wan backend and try one after other both autoconf protocols on encapsulated link. There should be some instructions from provider, or config page in their CPE.

According to the M-Net Datasheet:

Service access via PPPoE, authentication via PAP or CHAP.
Voice services with prioritization according to IEEE 802.1p and Ethernet packets with PCP value 5 (network priority 5).
Network protocols and standards:
TCP/IP with IPv6 DS-Lite (IPv6 DualStack optional at additional cost) with the following parameters:

  • IPv6 Configuration: SLAAC according to RFC 4862
  • IPv6 Assignment: DHCPv6 according to RFC 3315
  • DHCPv6 Option: DHCPv6 IAPD (DHCPv6 Identity Association for Prefix Delegation) according to RFC 3633
  • AFTR: aftr.prod.m-online.net

So ip6 is not provisioned via ppp, you need one of other autoconf protocols + install ds-lite support and configure aftr server.

But I get a prefix from the M-Net DHCPv6 server which I can use for addressing. Somehow my addressing in openwrt is incorrect.

like on wan6 or on pppoe-wan?

No on LAN. I guess this is meant by "Downstream Configuration": https://openwrt.org/docs/guide-user/network/ipv6/configuration#downstream_configuration_for_lan_interfaces

ff.... addresses are link-local, you need to get delegation from upstream.

Do you know how to configure this correctly in openwrt. I have only used MicroTik's RouterOS before.

That you need to ask your provider. Or figure out how to send rtsol or dhcp6 in pppoe tunnel.

But I get a prefix via dhcpv6:

Frame 19: 262 bytes on wire (2096 bits), 262 bytes captured (2096 bits) on interface unknown, id 0
Ethernet II, Src: ee:7c:5c:cb:23:47 (ee:7c:5c:cb:23:47), Dst: 52:aa:de:5b:f7:a6 (52:aa:de:5b:f7:a6)
PPP-over-Ethernet Session
Point-to-Point Protocol
Internet Protocol Version 6, Src: fe80::ee7c:5cff:fecb:2347, Dst: fe80::3511:4a0f:c382:f8da
User Datagram Protocol, Src Port: 547, Dst Port: 546
DHCPv6
    Message type: Advertise (2)
    Transaction ID: 0xe8290a
    Client Identifier
    Server Identifier
    Identity Association for Non-temporary Address
    Identity Association for Prefix Delegation
    DNS recursive name server

It is correct place for dhcp request and response, now further - does the address get configured on any interface?

Nope. I have attached a screenshot of the LuCI interface in the first post. I only get LL on wan and no ip on wan6

1 Like

Try to issue odhcp6c -v -v -v pppoe-wan command - maybe it says something interesting.