M-net DS-lite OpenWrt

Hello,
i am trying to build my own Router with Openwrt. My ISP is m-net and I have DS lite. Had anyone success with this or a similar configuration?

Not sure you can use a Nintendo DS Lite as a router....

If that's the wrong device, please provide additional information.

1 Like

I guess the OP is referring to Dual-Stack Lite, an IPv6 transition mechanism.

OpenWrt documentation:

Note that I don't use DS-Lite myself.

1 Like

That's right. As far as I know it is not very common outside of Germany...

Eigentlich ganz einfach

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option ds_snr_offset '0'
        option annex 'b2p'
        option xfer_mode 'ptm'
        option line_mode 'adsl'

config interface 'wan'                         
        option ifname 'dsl0.40'                
        option proto 'pppoe'                   
        option username 'Name'
        option password 'PW'                      
        option ipv6 '1'
 
config interface 'wan4'                                 
        option proto 'dslite'                           
        option peeraddr 'aftr.prod.m-online.net'        
        option encaplimit 'ignore'                      
                                                        
config interface 'wan6'                                 
        option ifname '@wan'                            
        option proto 'dhcpv6' 

I have tried to set it up like you said, however I get the following error: Network device not present. Is there anything else you configured? I tried to replace dsl0.40 with eth0.40 (because my Wan is in eth0) and then I had Internet for a short period of time. I am probable missing something obvious but how does your config tells openwrt where the wan access is?

So you are using an external modem? I have a TD-W8980 with built in modem. dsl0 defines the interface but for M-Net you have to use Vlan 40 for PPPOE so you have to define it via dsl0.40 but you would have to do that in you modem and not at eth0, thats my understanding.